Τώρα είναι Παρ 18 Οκτ 2019 08:58 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 07 Ιαν 2008 11:27 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 07 Ιαν 2008 11:23 pm
Δημοσιεύσεις: 1
θΕΛΩ ΤΙΣ ΛΥΣΕΙΣ ΤΗΣ ΤΡΙΤΟΒΑΘΜΙΑΣ αχ3+βχ2+γχ+δ σε αλγοριθμο


Τελευταία επεξεργασία από KOSTAS G. και Δευτ 14 Ιαν 2008 04:37 pm, έχει επεξεργασθεί 2 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 12 Ιαν 2008 06:00 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
Ελπίζω να σου κάνει...
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  EPILYSH_TRITOVATHMIAS
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: k
  ΠΡΑΓΜΑΤΙΚΕΣ: i, j, A, B, C, D, Y1,Y2,Y3,Y4
ΑΡΧΗ
  ΓΡΑΨΕ '********************************************************************'
  ΓΡΑΨΕ '*    ΠΡΟΓΡΑΜΜΑ ΕΥΡΕΣΗΣ ΠΡΑΓΜΑΤΙΚΩΝ ΡΙΖΩΝ ΜΕ ΠΡΟΣΕΓΓΙΣΗ ΕΚΑΤΟΣΤΟΥ   *'
  ΓΡΑΨΕ '*         ΤΡΙΤΟΒΑΘΜΙΑΣ ΕΞΙΣΩΣΗΣ ΣΤΟ ΔΙΑΣΤΗΜΑ [-100 .. 100]         *'
  ΓΡΑΨΕ '*                         ΕΚΔΟΣΗ 1.0                               *'
  ΓΡΑΨΕ '*                  Program made by periptero                       *'
  ΓΡΑΨΕ '********************************************************************'
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΥΣ ΣΥΝΤΕΛΕΣΤΕΣ ΤΟΥ ΤΡΙΩΝΥΜΟΥ αx^3+βx^2+γx+δ'
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ α: '
  ΔΙΑΒΑΣΕ A
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ β: '
  ΔΙΑΒΑΣΕ B
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ γ: '
  ΔΙΑΒΑΣΕ C
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ δ: '
  ΔΙΑΒΑΣΕ D
  k <-- 1
  ΓΡΑΨΕ 'ΕΥΡΕΣΗ ΡΙΖΩΝ ΣΤΟ ΔΙΑΣΤΗΜΑ ΑΠΟ [-100, 100] ΜΕ ΑΚΡΙΒΕΙΑ ΕΚΑΤΟΣΤΟΥ...'
  ΓΙΑ i  ΑΠΟ  -100  ΜΕΧΡΙ  100  ΜΕ ΒΗΜΑ  0.25
    Y1 <-- A*i^3+B*i^2+C*i+d
    Y2 <-- A*(i+1)^3+B*(i+1)^2+C*(i+1)+D
    ΑΝ Y1*Y2<0  ΤΟΤΕ
      ΓΙΑ j  ΑΠΟ  i  ΜΕΧΡΙ  i+0.25  ΜΕ ΒΗΜΑ  0.01
        Y3 <-- A*j^3+B*j^2+C*j+d
        Y4 <-- A*(j+0.01)^3+B*(j+0.01)^2+C*(j+0.01)+D
        ΑΝ Y3*Y4<0  ΤΟΤΕ
          ΓΡΑΨΕ 'Η', k,'η ΛΥΣΗ ΤΗΣ ΕΞΙΣΩΣΗΣ ΕΙΝΑΙ Η :', j
          k <-- k+1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ_ΑΝ Y1 = 0  ΤΟΤΕ
      ΓΡΑΨΕ 'Η', k,'η ΛΥΣΗ ΤΗΣ ΕΞΙΣΩΣΗΣ ΕΙΝΑΙ Η :', i
      k <-- k+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τετ 10 Οκτ 2012 04:57 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 10 Οκτ 2012 04:00 am
Δημοσιεύσεις: 7
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΕΞΙΣΩΣΕΙΣ_ΤΡΙΤΟΥ_ΒΑΘΜΟΥ
ΣΤΑΘΕΡΕΣ
  ΠΙ=3.14159265
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α,Β,Γ,Δ,P,Q,Φ,Ω,Υ
ΑΡΧΗ
  ΓΡΑΨΕ 'Θέστε τους συντελεστές'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Θέστε τον τριτοβάθμιο όρο'
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=0 ΤΟΤΕ
      ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
      ΓΡΑΨΕ ''
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Α<>0
  ΓΡΑΨΕ 'Θέστε τον δευτεροβάθμιο όρο'
  ΔΙΑΒΑΣΕ Β
  ΓΡΑΨΕ 'Θέστε τον πρωτοβάθμιο όρο'
  ΔΙΑΒΑΣΕ Γ
  ΓΡΑΨΕ 'Θέστε τον σταθερό όρο'
  ΔΙΑΒΑΣΕ Δ
  P <-- Γ/Α-Β^2/(3*Α^2)
  Q <-- (2*Β^3)/(27*Α^3)-(Β*Γ)/(3*Α^2)+Δ/Α
  Υ <-- -Β/(3*Α)
  Δ <-- (Q/2)^2+(P/3)^3
  ΑΝ Δ>0 ΤΟΤΕ
    Φ <-- -Q/2+ Τ_Ρ(Δ)
    Ω <-- -Q/2- Τ_Ρ(Δ)
    ΑΝ Φ<0 ΤΟΤΕ
      Φ <-- -Φ
      Φ <-- -Φ^(1/3)
    ΑΛΛΙΩΣ
      Φ <-- Φ^(1/3)
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ω<0 ΤΟΤΕ
      Ω <-- -Ω
      Ω <-- -Ω^(1/3)
    ΑΛΛΙΩΣ
      Ω  <-- Ω^(1/3)
    ΤΕΛΟΣ_ΑΝ
    Α <-- -(Φ+Ω)/2
    Β <-- Τ_Ρ(3)/2*(Φ-Ω)
    ΓΡΑΨΕ 'Μοναδική πραγματική λύση:'+Ω+Υ
    ΓΡΑΨΕ 'Συζυγείς μιγαδικές λύσεις:'
    ΓΡΑΨΕ Α+Υ,'+',Β,'i'
    ΓΡΑΨΕ Α+Υ,'-',Β,'i'
  ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
    ΑΝ Q=0 ΤΟΤΕ
      ΓΡΑΨΕ 'Τριπλή λύση:'
    ΑΛΛΙΩΣ_ΑΝ Q<0 ΤΟΤΕ
      ΓΡΑΨΕ 'Λύσεις:'
      Q <-- -Q
      ΓΡΑΨΕ ' Χ1=',2*(Q/2)^(1/3)+Υ
      ΓΡΑΨΕ ' Διπλή λύση:',-(Q/2)^(1/3)+Υ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Λύσεις:'
      ΓΡΑΨΕ ' Χ1=',-2*(Q/2)^(1/3)+Υ
      ΓΡΑΨΕ ' Διπλή λύση:',(Q/2)^(1/3)+Υ
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    Φ <-- -Q/2*Τ_Ρ((3/Α_Τ(P))^3)
    ΑΝ Φ<0 ΤΟΤΕ
      Φ <-- -Φ
      Φ <-- Τ_Ρ(1-Φ^2)/(1+Φ)
      Ω <-- ΠΙ-2*ΤΟΞΕΦ(Φ)
    ΑΛΛΙΩΣ
      Φ <-- Τ_Ρ(1-Φ^2)/(1+Φ)
      Ω <-- 2*ΤΟΞΕΦ(Φ)
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Λύσεις:'
    ΓΙΑ Α ΑΠΟ 0 ΜΕΧΡΙ 2
      ΓΡΑΨΕ ' Χ'+1,'=',2*Τ_Ρ(Α_Τ(P)/3)*ΣΥΝ((Ω+Α*2*ΠΙ)/3)+Υ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΤΟΞΕΦ(Χ): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Χ
ΑΡΧΗ
  ΤΟΞΕΦ <-- Χ/(1+Χ^2)+(2*Χ^3)/(3*(1+Χ^2)^2)+(8*Χ^5)/(15*(1+Χ^2)^3)+(16*Χ^7)/(35*(1+Χ^2)^4)
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

_________________
"Peace to everyone, and - who knows ? - maybe one day ... civilization !!!" - Pat Condell


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters