Τώρα είναι Παρ 18 Οκτ 2019 08:52 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 08 Ιαν 2011 12:31 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 08 Ιαν 2011 12:20 pm
Δημοσιεύσεις: 2
Αγαπητοί κύριοι έχω το εξής θέμα, δεν μπορώ να μεταφέρω τις τιμές ενός πίνακα (pass by value) απο το κυρίως πρόγραμμα στην διαδικασία μου. Πως μπορώ να το καταφέρω αυτό; Η παρακάτω δοκιμή εμφανίζει μήνυμα λάθους εκεί που σας δείχνω.


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΔΟΚΙΜΗ

ΣΤΑΘΕΡΕΣ
  Μ = 5        


ΜΕΤΑΒΛΗΤΕΣ      
  ΑΚΕΡΑΙΕΣ: i, Π[Μ], test

ΑΡΧΗ
  i <-- 1

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Μ
    Π[i] <-- i
    ΓΡΑΨΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  test <-- 6

  ΚΑΛΕΣΕ ΤΥΠΩΣΕ (Π[Μ], test)                                                        
           
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ ΤΥΠΩΣΕ (Π[Μ], test)    

ΣΤΑΘΕΡΕΣ                  
  Μ = 5

ΜΕΤΑΒΛΗΤΕΣ                      
  ΑΚΕΡΑΙΕΣ: i, Π[Μ], test

ΑΡΧΗ
  i <-- 1

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Μ
    ΓΡΑΨΕ Π[i] !<-----ΜΥΝΗΜΑ ΛΑΘΟΥΣ: Μη-αρχικοποιημένη μεταβλητή "Π[1]".  Επιχειρήθηκε η χρήση του περιεχομένου της μεταβλητής, χωρίς πρώτα να έχει εκχωρηθεί σε αυτήν κάποια τιμή.
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ test

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 09 Ιαν 2011 05:27 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Το
Syntax: [ Download ] [ Hide ]
  ΚΑΛΕΣΕ ΤΥΠΩΣΕ (Π[Μ], test)
πρέπει να το κάνεις
Syntax: [ Download ] [ Hide ]
  ΚΑΛΕΣΕ ΤΥΠΩΣΕ (Π, test)

και το
Syntax: [ Download ] [ Hide ]
ΔΙΑΔΙΚΑΣΙΑ ΤΥΠΩΣΕ (Π[Μ], test)
να το κάνεις
Syntax: [ Download ] [ Hide ]
ΔΙΑΔΙΚΑΣΙΑ ΤΥΠΩΣΕ (Π, test)


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 09 Ιαν 2011 06:45 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 08 Ιαν 2011 12:20 pm
Δημοσιεύσεις: 2
Ευχαριστώ πολύ!! Η απάντηση σου ήταν αμεσότατη!!


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters