Τώρα είναι Δευτ 26 Αύγ 2019 07:35 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 16 Ιαν 2011 07:19 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 02 Ιαν 2011 02:13 pm
Δημοσιεύσεις: 2
Να γραφεί σε μορφή ψευδοκώδικα το κυρίως πρόγραμμα μέσα από το οποίο διαβάζονται τα στοιχεία ενός μονοδιάστατου πίνακα χαρακτήρων, 10 στοιχείων. Έπειτα θα ζητείται από τον χρήστη να επιλέξει το στατιστικό στοιχείο που επιθυμεί (προσοχή, αυτό θα πρέπει να είναι στο διάστημα 1 έως 10) και, τέλος, θα εκτυπώνεται το επιλεγμένο στατιστικό στοιχείο στην οθόνη μετά από κλήση της διαδικασίας ΣΤΑΤΙΣΤΙΚΑ_ΔΙΑΤΑΞΗΣ

ΛΥΣΗ:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΔΙΑΧΩΡΙΣΜΟΣ_ΠΙΝΑΚΑ
ΣΤΑΘΕΡΕΣ
  g=10
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: d,left
  ΧΑΡΑΚΤΗΡΕΣ: b[g],right
ΑΡΧΗ
  για d από 1 μέχρι g
    γράψε 'δωστε δεδομενα'
    διάβασε b[d]
  τέλος_επανάληψης

  για d από 1 μέχρι g
    γράψε_ b[d]
  τέλος_επανάληψης
  γράψε
  γραψε

  για left από 1 μέχρι g-1
    για d από 1 μέχρι g - left + 1
      αν b[d]> b[g - left + 1] ΤΟΤΕ
        right <-- b[g - left + 1]
        b[g - left + 1] <-- b[d]
        b[d] <-- right
      τέλος_αν
    τέλος_επανάληψης
  τέλος_επανάληψης

  ΚΑΛΕΣΕ ΣΤΑΤΙΣΤΙΚΑ_ΔΙΑΤΑΞΗΣ(b,d)

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΣΤΑΤΙΣΤΙΚΑ_ΔΙΑΤΑΞΗΣ (b,d)
ΣΤΑΘΕΡΕΣ
  g = 10
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: b[g]
  ΑΚΕΡΑΙΕΣ: d,x
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΠΟΙΟ ΣΗΜΕΙΟ ΤΟΥ ΠΙΝΑΚΑ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΔΕΙΤΕ ?'
  ΔΙΑΒΑΣΕ x  
  αν x>g ΤΟΤΕ
   ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΣΩΣΤΟ ΣΗΜΕΙΟ ΤΟΥ ΠΙΝΑΚΑ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΔΕΙΤΕ ?'
   ΔΙΑΒΑΣΕ x
  τελος_αν  
  για d από 1 μέχρι g                          
    ΑΝ x = d ΤΟΤΕ
      γράψε 'ΤΟ ΣΗΜΕΙΟ ΠΟΥ ΔΙΑΛΕΞΑΤΕ ΠΕΡΙΕΧΕΙ ΤΟ ΓΡΑΜΜΑ'
      γράψε b[d]
    τέλος_αν
  τέλος_επανάληψης
τελος_διαδικασιας


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters