Τώρα είναι Τρί 31 Μαρ 2020 10:51 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: diabasma disdiastatoy pinaka
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 26 Ιαν 2009 03:39 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 24 Δεκ 2008 01:34 pm
Δημοσιεύσεις: 2
Geia sas, 8a h8ela poly na moy peite ton tropo me ton opoio mporoyme na diabasoyme enan disdiasto pinaka me thn xrhsh mias diadikasias me megisto plh8os grammvn 1000 kai sthlwn 10. thanks!!!! :wink:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: diabasma disdiastatoy pinaka
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 26 Ιαν 2009 05:02 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΟΡΙΣΤΕ Η ΑΠΑΝΤΗΣΗ :)
Syntax: [ Download ] [ Hide ]
 
ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
ΑΡΧΗ
  ΚΑΛΕΣΕ ΔΙΑΒΑΣΜΑ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΒΑΣΜΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , Κ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α[1000,10] !ΤΟΝ ΠΙΝΑΚΑ ΜΠΟΡΕΙΣ ΝΑ ΤΟΝ ΔΗΛΩΣΕΙΣ
ΑΡΧΗ                      !ΚΑΙ ΣΕ ΟΠΟΙΟ ΕΙΔΟΣ ΜΕΤΑΒΛΗΤΩΝ ΣΟΥ ΖΗΤΑΕΙ Η ΑΣΚΗΣΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 1000
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 10
      ΔΙΑΒΑΣΕ Α[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


ΧΑΡΗΚΑ ΠΟΥ ΒΟΗΘΗΣΑ :D

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: diabasma disdiastatoy pinaka
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 06 Απρ 2009 11:33 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 25 Φεβ 2009 12:19 am
Δημοσιεύσεις: 8
:idea:
Syntax: [ Download ] [ Hide ]
!Η προηγούμενη εκδοχή είναι διδακτικά πολύ καλή
!και καλύπτει το ζητούμενο όπως αυτό διατυπώνεται,
!αλλά δεν επιτρέπει την "επιστροφή" του
!πίνακα στο κύριο πρόγραμμα, με αποτέλεσμα να μην είναι
!δυνατή η πρόσβαση σε αυτόν από άλλα υποπρογράμματα.
!Ίσως η ακόλουθη εκδοχή να είναι λιγότερο διδακτική,
!αλλά περισσότερο χρηστική.
!Για ευκολία στην εκτέλεση έχουν μειωθεί οι διαστάσεις
!του πίνακα. Επίσης δε γίνεται έλεγχος εγκυρότητας
!ως προς τις τιμές των i και j που εισάγει ο χρήστης
!μια που ο σκοπός του παραδείγματος είναι άλλος.

ΠΡΟΓΡΑΜΜΑ Άσκηση
  ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ: i, j
    ΠΡΑΓΜΑΤΙΚΕΣ: Β[4,2]
  ΑΡΧΗ
    ΚΑΛΕΣΕ ΔΙΑΒΑΣΜΑ(Β)
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ i
      ΑΝ i<>0 ΤΟΤΕ
        ΔΙΑΒΑΣΕ j
        ΓΡΑΨΕ 'Το στοιχείο', i, ',', j, 'είναι', Β[i,j]
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ i=0
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΒΑΣΜΑ(Α)
  ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ: Ι , Κ
    ΠΡΑΓΜΑΤΙΚΕΣ: Α[4,2] !ΤΟΝ ΠΙΝΑΚΑ ΜΠΟΡΕΙΣ ΝΑ ΤΟΝ ΔΗΛΩΣΕΙΣ
  ΑΡΧΗ                      !ΚΑΙ ΣΕ ΟΠΟΙΟ ΕΙΔΟΣ ΜΕΤΑΒΛΗΤΩΝ ΣΟΥ ΖΗΤΑΕΙ Η ΑΣΚΗΣΗ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 4
      ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 2
        ΔΙΑΒΑΣΕ Α[Ι,Κ]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


Ελπίζω όπως η πρώτη λύση αποτέλεσε για μένα τροφή για σκέψη, έτσι και η προσθήκη να φανεί χρήσιμη σε κάποιους
:)


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters