Τώρα είναι Τρί 31 Μαρ 2020 09:39 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμοί και διασκέδαση
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 03 Νοέμ 2007 11:13 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 03 Νοέμ 2007 07:52 pm
Δημοσιεύσεις: 1
Τοποθεσία: μυτιλήνη λέσβος
Να ένα πρόγραμμα που συνδιάζει πολλές διαφορετικές λειτουργίες, όποτε τις θέλεις και όσες φορές τις θέλεις.

Για να χρησιμοποιήσεις το παρακάτω πρόγραμμα πρέπει να χρησιμοποιείς μόνο τις παρακάτω φράσεις:

όγκος πρίσματος
όγκος πυραμίδας
εμβαδόν κανονικού πολυγώνου
εμβαδόν ορθογωνίου παραλληλογράμμου
εμβαδόν τετραγώνου
εμβαδόν τραπεζίου
εμβαδόν τριγώνου
όγκος κύβου
όγκος ορθογωνίου παραλληλεπιπέδου
όγκος σφαίρας
υποτείνουσα τριγώνου
πρόσθεση
πολλαπλασιασμός
διαίρεση
αφαίρεση
όχι
ναι
πέτρα
ψαλίδι
χαρτί
πέτρα-ψαλίδι-χαρτί
αστεία
υπολογισμοί
ψυχαγωγία

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΡΤ

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: χ, κ

ΑΡΧΗ

  ΓΡΑΨΕ 'Ποια είναι η 1η λειτουργία που θέλεις να κάνω.'

  ΔΙΑΒΑΣΕ χ

  ΑΝ χ='υπολογισμοί' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_1
  ΑΛΛΙΩΣ_ΑΝ χ='ψυχαγωγία' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_2

  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Θέλεις να δουλέψουμε σε κάτι άλλο τώρα;'

  ΔΙΑΒΑΣΕ κ

  ΑΝ κ='ναι' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_3

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Χ_1

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ, δ
  ΧΑΡΑΚΤΗΡΕΣ:εντολή, χχ

ΑΡΧΗ

  ΓΡΑΨΕ 'Σε τι μπορώ να σε βοηθήσω ;'

  ΔΙΑΒΑΣΕ εντολή

  ΑΝ εντολή='όγκος πρίσματος' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε την πλευρά του πολυγώνου της βάσης:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε το ύψος του πολυγώνου της βάσης:'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώσε τον αριθμό των γωνιών του πολυγώνου της βάσης:'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Δώσε το ύψος του πρίσματος:'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='όγκος πυραμίδας' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε τη πλευρά του κανονικού πολυγώνου της βάσης:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε το ύψος του κανονικού πολυγώνο της βάσης:'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώσε τον αριθμό των πλευρών του κανονικού πολυγώνου της βάσης:'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Δώσε το ύψος της πυραμίδας:'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='εμβαδόν κανονικού πολυγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε την πλευρά:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε το ύψος:'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώσε τον αριθμό των γωνιών:'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='εμβαδόν ορθογωνίου παραλληλογράμμου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε τη βάση:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε το ύψος:'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='εμβαδόν τετραγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε την πλευρά :'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='εμβαδόν τραπεζίου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε τη μεγάλη βάση:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε τη μικρή βαση:'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώσε το ύψος:'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='εμβαδόν τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε το ύψος:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε τη βάση:'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='όγκος κύβου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε την πλευρά:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='όγκος ορθογωνίου παραλληλεπιπέδου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε το μήκος:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε το πλάτος:'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώσε το ύψος:'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='όγκος σφαίρας' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε την ακτίνα της σφαίρας.'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='υποτείνουσα τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε το μήκος της πρώτης προσκείμενης πλευράς.'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε το μήκος της δεύτερης προσκείμενης πλευράς.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γράψε 0.'
    ΔΙΑΒΑΣΕ δ
    ΓΡΑΨΕ

  ΑΛΛΙΩΣ_ΑΝ εντολή='πρόσθεση' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε μου τον πρώτο προσθεταίο.'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε μου τον δεύτερο προσθεταίο.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώσε μου τον τρίτο προσθεταίο.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Δώσε μου τον τέταρτο προσθεταίο.'
    ΔΙΑΒΑΣΕ δ

  ΑΛΛΙΩΣ_ΑΝ εντολή='πολλαπλασιασμός' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε μου τον πρώτο παράγοντα.'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε μου τον δεύτερο παράγοντα.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώσε μου τον τρίτο παράγοντα.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Δώσε μου τον τέταρτο παράγοντα.'
    ΔΙΑΒΑΣΕ δ

  ΑΛΛΙΩΣ_ΑΝ εντολή='διαίρεση' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε μου τον διαιρέτη.'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε μου τον διαιρεταίο.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γραψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γραψε 0.'
    ΔΙΑΒΑΣΕ δ

  ΑΛΛΙΩΣ_ΑΝ εντολή='αφαίρεση' ΤΟΤΕ
    ΓΡΑΨΕ 'Δώσε μου τον μειωταίο.'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώσε μου τον αφαιρεταίο.'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γραψε 0.'
    ΔΙΑΒΑΣΕ γ
    ΓΡΑΨΕ 'Στην επόμενη μεταβλητή γραψε 0.'
    ΔΙΑΒΑΣΕ δ

  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='όγκος πρίσματος' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='όγκος πρίσματος' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ γ < 0 ΚΑΙ εντολή='όγκος πρίσματος' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ δ < 0 ΚΑΙ εντολή='όγκος πρίσματος' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ α*β*γ*δ >= 0 ΚΑΙ εντολή='όγκος πρίσματος' ΤΟΤΕ
    ΓΡΑΨΕ 'όγκος πρίσματος =', α*β*γ*δ*1/2
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='όγκος πυραμίδας' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='όγκος πυραμίδας' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ γ < 0 ΚΑΙ εντολή='όγκος πυραμίδας' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ δ < 0 ΚΑΙ εντολή='όγκος πυραμίδας' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ α*β*γ*δ >= 0 ΚΑΙ εντολή='όγκος πυραμίδας' ΤΟΤΕ
    ΓΡΑΨΕ 'όγκος πυραμίδας =', α*β*γ*δ*1/6
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='εμβαδόν κανονικού πολυγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='εμβαδόν κανονικού πολυγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ γ < 0 ΚΑΙ εντολή='εμβαδόν κανονικού πολυγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ α*β*γ*1/2 >= 0 ΚΑΙ εντολή='εμβαδόν κανονικού πολυγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'εμβαδόν κανονικού πολυγώνου =', α*β*γ*1/2
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='εμβαδόν ορθογωνίου παραλληλογράμμου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='εμβαδόν ορθογωνίου παραλληλογράμμου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ α*β >= 0 ΚΑΙ εντολή='εμβαδόν ορθογωνίου παραλληλογράμμου' ΤΟΤΕ
    ΓΡΑΨΕ 'εμβαδόν ορθογωνίου παραλληλόγραμου =', α*β
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='εμβαδόν τετραγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ α >= 0 ΚΑΙ εντολή='εμβαδόν τετραγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'εμβαδόν τετραγώνου =', α^2
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='εμβαδόν τραπεζίου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='εμβαδόν τραπεζίου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ γ < 0 ΚΑΙ εντολή='εμβαδόν τραπεζίου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ α < β ΚΑΙ εντολή='εμβαδόν τραπεζίου' ΤΟΤΕ
    ΓΡΑΨΕ 'Η μικρή βάση είναι πιο μεγάλη από τη μεγάλη βάση.'
  ΑΛΛΙΩΣ_ΑΝ (α+β)*γ/2 >= 0 ΚΑΙ εντολή='εμβαδόν τραπεζίου' ΤΟΤΕ
    ΓΡΑΨΕ 'εμβαδόν τραπεζίου =', (α+β)*γ/2
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='εμβαδόν τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='εμβαδόν τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό εμβαδόν.'
  ΑΛΛΙΩΣ_ΑΝ α*β*1/2 >= 0 ΚΑΙ εντολή='εμβαδόν τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'εμβαδόν τριγώνου =', α*β*1/2
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='όγκος κύβου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ α >= 0 ΚΑΙ εντολή='όγκος κύβου' ΤΟΤΕ
    ΓΡΑΨΕ 'όγκος κύβου =', α^3
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='όγκος ορθογωνίου παραλληλεπιπέδου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='όγκος ορθογωνίου παραλληλεπιπέδου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ γ < 0 ΚΑΙ εντολή='όγκος ορθογωνίου παραλληλεπιπέδου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ α*β*γ >= 0 ΚΑΙ εντολή='όγκος ορθογωνίου παραλληλεπιπέδου' ΤΟΤΕ
    ΓΡΑΨΕ 'όγκος ορθογωνίου παραλληλεπιπέδου =', α*β*γ
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='όγκος σφαίρας' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικός όγκος.'
  ΑΛΛΙΩΣ_ΑΝ α >= 0 ΚΑΙ εντολή='όγκος σφαίρας' ΤΟΤΕ
    ΓΡΑΨΕ 'Όγκος σφαίρας =', (314/100)*α^3*4/3
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α < 0 ΚΑΙ εντολή='υποτείνουσα τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό μήκος.'
  ΑΛΛΙΩΣ_ΑΝ β < 0 ΚΑΙ εντολή='υποτείνουσα τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Δεν υπάρχει αρνητικό μήκος.'
  ΑΛΛΙΩΣ_ΑΝ  α*α+β*β >= 0 ΚΑΙ εντολή='υποτείνουσα τριγώνου' ΤΟΤΕ
    ΓΡΑΨΕ 'Υποτείνουσα =', Τ_Ρ(α^2+β^2)
  ΤΕΛΟΣ_ΑΝ

  ΑΝ εντολή='πρόσθεση' ΤΟΤΕ
    ΓΡΑΨΕ 'Αποτέλεσμα πρόσθεσης ='+β+γ+δ
  ΤΕΛΟΣ_ΑΝ

  ΑΝ εντολή='πολλαπλασιασμός' ΤΟΤΕ
    ΓΡΑΨΕ 'Αποτέλεσμα πολλαπλασιασμού ='*β*γ*δ
  ΤΕΛΟΣ_ΑΝ

  ΑΝ εντολή='διαίρεση' ΤΟΤΕ
    ΓΡΑΨΕ 'Αποτέλεσμα διαίρεσης ='/β
  ΤΕΛΟΣ_ΑΝ

  ΑΝ εντολή='αφαίρεση' ΤΟΤΕ
    ΓΡΑΨΕ 'Αποτέλεσμα αφαίρεσης ='-β
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Θέλεις να ξαναδουλεύσουμε το ίδιο ξανα;'

  ΔΙΑΒΑΣΕ χχ

  ΑΝ χχ='ναι' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_1

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Χ_2

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: απάντηση4

ΑΡΧΗ

  ΓΡΑΨΕ 'Θέλεις να πούμε αστεία ή να παίξουμε πέτρα-ψαλίδι-χαρτί.'

  ΔΙΑΒΑΣΕ απάντηση4

  ΑΝ απάντηση4='πέτρα-ψαλίδι-χαρτί' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_5
  ΑΛΛΙΩΣ_ΑΝ απάντηση4='αστεία' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_6

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Χ_3

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: λ, ν

ΑΡΧΗ

  ΓΡΑΨΕ 'Ποια είναι η επόμενη λειτουργία που θέλεις να κάνω;'

  ΔΙΑΒΑΣΕ λ

  ΑΝ λ='υπολογισμοί' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_1
  ΑΛΛΙΩΣ_ΑΝ λ='ψυχαγωγία' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_2

  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Θέλεις να ξαναδουλεύσουμε σε κάτι άλλο;'
  ΔΙΑΒΑΣΕ ν

  ΑΝ ν='ναι' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_3

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Χ_5

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: t
  ΧΑΡΑΚΤΗΡΕΣ: f, d

ΑΡΧΗ

  ΓΡΑΨΕ 'Πες μου τι έβγαλες;'

  ΔΙΑΒΑΣΕ f

  ΓΡΑΨΕ'Δώσε έναν αριθμό από το 1 μέχρι το 3.'

  ΔΙΑΒΑΣΕ t

  ΑΝ f='πέτρα' ΚΑΙ t=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Έχασα. Εγώ έχω ψαλίδι.'
  ΑΛΛΙΩΣ_ΑΝ f='ψαλίδι' ΚΑΙ t=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Εγώ έχω ψαλίδι. Άρα ήμαστε ισοπαλία.'
  ΑΛΛΙΩΣ_ΑΝ f='χαρτί' ΚΑΙ t=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Ευτυχώς. Έβγαλα ψαλίδι. Νίκησα.'
  ΑΛΛΙΩΣ_ΑΝ f='πέτρα' ΚΑΙ t=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Έχασες. Έβγαλα χαρτί.'
  ΑΛΛΙΩΣ_ΑΝ f='ψαλίδι' ΚΑΙ t=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Νίκησες. Έχω χαρτί.'
  ΑΛΛΙΩΣ_ΑΝ f='χαρτί' ΚΑΙ t=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Έχω χαρτί. Ισοπαλία.'
  ΑΛΛΙΩΣ_ΑΝ f='πέτρα' ΚΑΙ t=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Ισοπαλία. Κι εγώ πέτρα έχω!'
  ΑΛΛΙΩΣ_ΑΝ f='ψαλίδι' ΚΑΙ t=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Νίκησα. Εγώ εχώ πέτρα.'
  ΑΛΛΙΩΣ_ΑΝ f='χαρτί' ΚΑΙ t=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Νίκη για εσένα. Πέτρα έχω.'

  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Θέλεις κι άλλη παρτίδα;'

  ΔΙΑΒΑΣΕ d

  ΑΝ d='ναι' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_8

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Χ_6

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: t
  ΧΑΡΑΚΤΗΡΕΣ: l

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε μου έναν αριθμό από το 1 μέχρι το 7.'

  ΔΙΑΒΑΣΕ t

  ΑΝ t=1 ΤΟΤΕ
    ΓΡΑΨΕ'Τι κοινό έχουν τα χρήματα με τα ψάρια;'
    ΓΡΑΨΕ'Τρώγονται πάντα φρέσκα.'
  ΑΛΛΙΩΣ_ΑΝ t=2 ΤΟΤΕ
    ΓΡΑΨΕ'Τι παθαίνουν τα βλήτα όταν τρομάξουν;'
    ΓΡΑΨΕ'Γίνονται πανικόβλητα.'
  ΑΛΛΙΩΣ_ΑΝ t=3 ΤΟΤΕ
    ΓΡΑΨΕ'Ποίο είναι το ακριβώς αντίθετο του"αρνάκι'
    ΓΡΑΨΕ'άσπρο και παχύ της μάνας του το καμάρι";'
    ΓΡΑΨΕ'"Λύκος μαύρος και ίσχνος του πατέρα του ο καημός"'
  ΑΛΛΙΩΣ_ΑΝ t=4 ΤΟΤΕ
    ΓΡΑΨΕ'Πως λέγεται αυτός που έχει δύο μάτια;'
    ΓΡΑΨΕ'Διπλομάτης.'
  ΑΛΛΙΩΣ_ΑΝ t=5 ΤΟΤΕ
    ΓΡΑΨΕ'Ποιό είναι το αντίθετο του πείθω;'
    ΓΡΑΨΕ'Το μπροθτά.'
  ΑΛΛΙΩΣ_ΑΝ t=6 ΤΟΤΕ
    ΓΡΑΨΕ'Πότε πήρε κλήση η πάπια από την τροχαία;'
    ΓΡΑΨΕ'Μικρή όταν ήταν παπάκι.'
  ΑΛΛΙΩΣ_ΑΝ t=7 ΤΟΤΕ
    ΓΡΑΨΕ'Ποιο είναι το θυληκό του γκαρσόν;'
    ΓΡΑΨΕ'Γκαρσονίερα.'

  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Θέλεις κι άλλο ανέκδοτο;'

  ΔΙΑΒΑΣΕ l

  ΑΝ l='ναι' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_7

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Χ_7

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: p
  ΧΑΡΑΚΤΗΡΕΣ: m

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε μου έναν αριθμό από το 1 μέχρι το 7.'

  ΔΙΑΒΑΣΕ p

  ΑΝ p=7 ΤΟΤΕ
    ΓΡΑΨΕ'Τι κοινό έχουν τα χρήματα με τα ψάρια;'
    ΓΡΑΨΕ'Τρώγονται πάντα φρέσκα.'
  ΑΛΛΙΩΣ_ΑΝ p=4 ΤΟΤΕ
    ΓΡΑΨΕ'Τι παθαίνουν τα βλήτα όταν τρομάξουν;'
    ΓΡΑΨΕ'Γίνονται πανικόβλητα.'
  ΑΛΛΙΩΣ_ΑΝ p=6 ΤΟΤΕ
    ΓΡΑΨΕ'Ποίο είναι το ακριβώς αντίθετο του"αρνάκι'
    ΓΡΑΨΕ'άσπρο και παχύ της μάνας του το καμάρι";'
    ΓΡΑΨΕ'"Λύκος μαύρος και ίσχνος του πατέρα του ο καημός"'
  ΑΛΛΙΩΣ_ΑΝ p=5 ΤΟΤΕ
    ΓΡΑΨΕ'Πως λέγεται αυτός που έχει δύο μάτια;'
    ΓΡΑΨΕ'Διπλομάτης.'
  ΑΛΛΙΩΣ_ΑΝ p=3 ΤΟΤΕ
    ΓΡΑΨΕ'Ποιό είναι το αντίθετο του πείθω;'
    ΓΡΑΨΕ'Το μπροθτά.'
  ΑΛΛΙΩΣ_ΑΝ p=2 ΤΟΤΕ
    ΓΡΑΨΕ'Πότε πήρε κλήση η πάπια από την τροχαία;'
    ΓΡΑΨΕ'Μικρή όταν ήταν παπάκι.'
  ΑΛΛΙΩΣ_ΑΝ p=1 ΤΟΤΕ
    ΓΡΑΨΕ'Ποιο είναι το θυληκό του γκαρσόν;'
    ΓΡΑΨΕ'Γκαρσονίερα.'

  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Θέλεις κι άλλο ανέκδοτο;'
  ΔΙΑΒΑΣΕ m

  ΑΝ m='ναι' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_6

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ Χ_8

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: mm
  ΧΑΡΑΚΤΗΡΕΣ: g, h

ΑΡΧΗ

  ΓΡΑΨΕ 'Πες μου τι έβγαλες;'

  ΔΙΑΒΑΣΕ g

  ΓΡΑΨΕ 'Δώσε έναν αριθμό από το 1 μέχρι το 3.'

  ΔΙΑΒΑΣΕ mm

  ΑΝ g='πέτρα' ΚΑΙ mm=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Έχασα. Εγώ έχω ψαλίδι.'
  ΑΛΛΙΩΣ_ΑΝ g='ψαλίδι' ΚΑΙ mm=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Εγώ έχω ψαλίδι. Άρα ήμαστε ισοπαλία.'
  ΑΛΛΙΩΣ_ΑΝ g='χαρτί' ΚΑΙ mm=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Ευτυχώς. Έβγαλα ψαλίδι. Νίκησα.'
  ΑΛΛΙΩΣ_ΑΝ g='πέτρα' ΚΑΙ mm=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Έχασες. Έβγαλα χαρτί.'
  ΑΛΛΙΩΣ_ΑΝ g='ψαλίδι' ΚΑΙ mm=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Νίκησες. Έχω χαρτί.'
  ΑΛΛΙΩΣ_ΑΝ g='χαρτί' ΚΑΙ mm=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Έχω χαρτί. Ισοπαλία.'
  ΑΛΛΙΩΣ_ΑΝ g='πέτρα' ΚΑΙ mm=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Ισοπαλία. Κι εγώ πέτρα έχω!'
  ΑΛΛΙΩΣ_ΑΝ g='ψαλίδι' ΚΑΙ mm=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Νίκησα. Εγώ εχώ πέτρα.'
  ΑΛΛΙΩΣ_ΑΝ g='χαρτί' ΚΑΙ mm=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Νίκη για εσένα. Πέτρα έχω.'

  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Θέλεις κι άλλη παρτίδα;'
  ΔΙΑΒΑΣΕ h

  ΑΝ h='ναι' ΤΟΤΕ
    ΚΑΛΕΣΕ Χ_5

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Αν μπορείτε γράψτε σχόλια και ιδέες.

_________________
V@g-lis


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters