Τώρα είναι Τρί 31 Μαρ 2020 10:28 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 27 Οκτ 2007 11:04 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
Παρακάτω σας παραθέτω ένα πλήρες (κατά τη γνώμη μου) πρόγραμμα υπολογισμού των μορίων πρόσβασης στην Τριτοβάθμια Εκπαίδευση. Είναι λίγο μεγάλο (977 γραμμές !!!). Κατά τη μεταγλώττιση ή την εκτέλεση κάνει γύρω στα 3 λεπτά για να εκτελεστεί... Γι΄αυτό λίγο υπομονή. Είναι προτιμότερο να δημιουργήσετε ένα εκτελέσιμο αρχείο και να το τρέχετε. Θα σας γλιτώσει αρκετό χρόνο για να το δείτε. Παρακάτω φαίνεται ο κώδικας:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Υπολογισμός_μορίων_Πρόσβασης_στη_Τριτοβάθμια_Εκπαίδευση
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: x,y1,y2,y3,y4,y5
ΑΡΧΗ
  ΓΡΑΨΕ ' Καλωσήρθατε στο πρόγραμμα υπολογισμού των μορίων '
  ΓΡΑΨΕ ' πρόσβασης στην Τριτοβάθμια Εκπαίδευση '
  ΓΡΑΨΕ ' Παρακαλώ διαλέξτε ποια κατεύθυνση είστε '
  ΓΡΑΨΕ ' 1. Θεωρητική '
  ΓΡΑΨΕ ' 2. Θετική '
  ΓΡΑΨΕ ' 3. Τεχνολογική (Κύκλος Πληροφορικής) '
  ΓΡΑΨΕ ' 4. Τεχνολογική (Κύκλος Τεχνολογίας) '
  ΓΡΑΨΕ ' Παρακαλώ πληκτρολογήστε τον κατάλληλο αριθμό για την ανάλογη κατεύθυνση σπουδών: '
  ΔΙΑΒΑΣΕ x
  ΑΝ x=1 ΤΟΤΕ
    ΚΑΛΕΣΕ theoritikh(y1,y2,y3,y4,y5)
  ΑΛΛΙΩΣ_ΑΝ x=2  ΤΟΤΕ
    ΚΑΛΕΣΕ thetikh(y1,y2,y3,y4,y5)
  ΑΛΛΙΩΣ_ΑΝ x=3  ΤΟΤΕ
    ΚΑΛΕΣΕ texnologikh_1(y1,y2,y3,y4,y5)
  ΑΛΛΙΩΣ_ΑΝ x=4  ΤΟΤΕ
    ΚΑΛΕΣΕ texnologikh_2(y1,y2,y3,y4,y5)
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ ' Πληκτρολογήσατε λανθασμένη επιλογή. Το πρόγραμμα θα τερματιστεί. '
  ΤΕΛΟΣ_ΑΝ
  ΑΝ x=1  ΤΟΤΕ
    ΓΡΑΨΕ 'Τα μόρια που πήρατε στις Πανελλήνιες Εξετάσεις φαίνονται Παρακάτω:'
    ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 1ο Επιστημονικό Πεδίο είναι :', y1, 'μόρια'
    ΑΝ y2=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 2ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 2ο Επιστημονικό Πεδίο είναι :', y2, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y3=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 3ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 3ο Επιστημονικό Πεδίο είναι :', y3, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y4=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 4ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 4ο Επιστημονικό Πεδίο είναι :', y4, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y5=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 5ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 5ο Επιστημονικό Πεδίο είναι :', y5, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ x=2  ΤΟΤΕ
    ΓΡΑΨΕ 'Τα μόρια που πήρατε στις Πανελλήνιες Εξετάσεις φαίνονται Παρακάτω:'
    ΑΝ y1=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 1ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 1ο Επιστημονικό Πεδίο είναι :', y1, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y2=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 2ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 2ο Επιστημονικό Πεδίο είναι :', y2, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y3=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 3ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 3ο Επιστημονικό Πεδίο είναι :', y3, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y4=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 4ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 4ο Επιστημονικό Πεδίο είναι :', y4, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y5=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 5ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 5ο Επιστημονικό Πεδίο είναι :', y5, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ  x=3  ΤΟΤΕ
    ΓΡΑΨΕ 'Τα μόρια που πήρατε στις Πανελλήνιες Εξετάσεις φαίνονται Παρακάτω:'
    ΑΝ y1=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 1ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 1ο Επιστημονικό Πεδίο είναι :', y1, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y2=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 2ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 2ο Επιστημονικό Πεδίο είναι :', y2, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y3=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 3ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 3ο Επιστημονικό Πεδίο είναι :', y3, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y4=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 4ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 4ο Επιστημονικό Πεδίο είναι :', y4, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y5=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 5ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 5ο Επιστημονικό Πεδίο είναι :', y5, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ x=4  ΤΟΤΕ
    ΓΡΑΨΕ 'Τα μόρια που πήρατε στις Πανελλήνιες Εξετάσεις φαίνονται Παρακάτω:'
    ΑΝ y1=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 1ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 1ο Επιστημονικό Πεδίο είναι :', y1, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y2=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 2ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 2ο Επιστημονικό Πεδίο είναι :', y2, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y3=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 3ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 3ο Επιστημονικό Πεδίο είναι :', y3, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y4=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 4ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 4ο Επιστημονικό Πεδίο είναι :', y4, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ y5=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν έχετε δικαίωμα να δηλώσετε σχολές του 5ου Επιστημονικού Πεδίου '
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Τα Μόρια που συγκεντρώσατε στο 5ο Επιστημονικό Πεδίο είναι :', y5, 'μόρια'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ' ************************* '
  ΓΡΑΨΕ ' Program made by Periptero '
  ΓΡΑΨΕ ' ************************* '
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ theoritikh(x1,x2,x3,x4,x5)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: s,s1
  ΠΡΑΓΜΑΤΙΚΕΣ: a[7,4],b[8],temp,x1,x2,x3,x4,x5
ΑΡΧΗ
  s1 <-- 0
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α','τετράμηνο στα Αρχαία Ελληνικά Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B','τετράμηνο στα Αρχαία Ελληνικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[1,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Αρχαία Ελληνικά Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Νεολληνική Λογοτεχνία'
  ΔΙΑΒΑΣΕ a[2,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Νεολληνική Λογοτεχνία'
  ΔΙΑΒΑΣΕ a[2,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Νεολληνική Λογοτεχνία '
  ΔΙΑΒΑΣΕ a[2,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στα Λατινικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στα Λατινικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Λατινικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στην Ιστορία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[4,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στην Ιστορία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[4,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στην Ιστορία Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[4,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Νεολληνική Γλώσσα '
  ΔΙΑΒΑΣΕ a[5,3]
  ΓΡΑΨΕ ' Παρακαλώ διαλέξτε ποιο μάθημα Γενικής Παιδείας εξετάζεστε σε Πανελλαδικό Επίπεδο '
  ΓΡΑΨΕ ' 1. Ιστορία Γενικής Παιδείας '
  ΓΡΑΨΕ ' 2. Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
  ΓΡΑΨΕ ' 3. Φυσική Γενικής Παιδείας '
  ΓΡΑΨΕ ' 4. Βιολογία Γενικής Παιδείας '
  ΔΙΑΒΑΣΕ s
  ΑΝ s = 1  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στην Ιστορία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 2  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
    ΓΡΑΨΕ ' Δώσατε το επιλεγόμενο μάθημα Αρχές Οικονομικής Θεωρίας '
    ΓΡΑΨΕ ' 1. Ναι '
    ΓΡΑΨΕ ' 2. Όχι '
    ΔΙΑΒΑΣΕ s1
    ΑΝ s1 = 1  ΤΟΤΕ
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,1]
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας'
      ΔΙΑΒΑΣΕ a[7,2]
      ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,3]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s = 3  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Φυσική Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 4  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Βιολογία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ ' Δεν διαλέξατε κάποια έγκυρη επιλογή '
  ΤΕΛΟΣ_ΑΝ
  a[1,4] <-- (a[1,1]+a[1,2])/2
  temp <-- Α_Τ(a[1,4]-a[1,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[1,4]>a[1,3]  ΤΟΤΕ
      a[1,4] <-- a[1,3] + 2
    ΑΛΛΙΩΣ
      a[1,4] <-- a[1,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[1] <-- a[1,4] * 0.3 + a[1,3] * 0.7
  a[2,4] <-- (a[2,1]+a[2,2])/2
  temp <-- Α_Τ(a[2,4]-a[2,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[2,4]>a[2,3]  ΤΟΤΕ
      a[2,4] <-- a[2,3] + 2
    ΑΛΛΙΩΣ
      a[2,4] <-- a[2,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[2] <-- a[2,4] * 0.3 + a[2,3] * 0.7
  a[3,4] <-- (a[3,1]+a[3,2])/2
  temp <-- Α_Τ(a[3,4]-a[3,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[3,4]>a[3,3]  ΤΟΤΕ
      a[3,4] <-- a[3,3] + 2
    ΑΛΛΙΩΣ
      a[3,4] <-- a[3,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[3] <-- a[3,4] * 0.3 + a[3,3] * 0.7
  a[4,4] <-- (a[4,1]+a[4,2])/2
  temp <-- Α_Τ(a[4,4]-a[4,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[4,4]>a[4,3]  ΤΟΤΕ
      a[4,4] <-- a[4,3] + 2
    ΑΛΛΙΩΣ
      a[4,4] <-- a[4,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[4] <-- a[4,4] * 0.3 + a[4,3] * 0.7
  a[5,4] <-- (a[5,1]+a[5,2])/2
  temp <-- Α_Τ(a[5,4]-a[5,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[5,4]>a[5,3]  ΤΟΤΕ
      a[5,4] <-- a[5,3] + 2
    ΑΛΛΙΩΣ
      a[5,4] <-- a[5,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[5] <-- a[5,4] * 0.3 + a[5,3] * 0.7
  a[6,4] <-- (a[6,1]+a[6,2])/2
  temp <-- Α_Τ(a[6,4]-a[6,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[6,4]>a[6,3]  ΤΟΤΕ
      a[6,4] <-- a[6,3] + 2
    ΑΛΛΙΩΣ
      a[6,4] <-- a[6,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[6] <-- a[6,4] * 0.3 + a[6,3] * 0.7
  ΑΝ s1 = 1  ΤΟΤΕ
    a[7,4] <-- (a[7,1]+a[7,2])/2
    temp <-- Α_Τ(a[7,4]-a[7,3])
    ΑΝ  temp > 2  ΤΟΤΕ
      ΑΝ  a[7,4]>a[7,3]  ΤΟΤΕ
        a[7,4] <-- a[7,3] + 2
      ΑΛΛΙΩΣ
        a[7,4] <-- a[7,3] - 2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    b[7] <-- a[7,4] * 0.3 + a[7,3] * 0.7
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6]+b[7])/7
  ΑΛΛΙΩΣ
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6])/6
  ΤΕΛΟΣ_ΑΝ
  ΑΝ s = 1 ΤΟΤΕ
    x1 <-- b[1]*130+b[2]*70+b[8]*800
    x2 <-- 0
    x3 <-- 0
    x4 <-- 0
    x5 <-- 0
  ΑΛΛΙΩΣ_ΑΝ s = 2 ΤΟΤΕ
    ΑΝ s1 = 1  ΤΟΤΕ
      x1 <-- b[1]*130+b[2]*70+b[8]*800
      x2 <-- b[6]*90+b[5]*40+b[8]*800
      x3 <-- 0
      x4 <-- b[6]*90+b[5]*40+b[8]*800
      x5 <-- b[7]*130+b[6]*70+b[8]*800
    ΑΛΛΙΩΣ
      x1 <-- b[1]*130+b[2]*70+b[8]*800
      x2 <-- b[6]*90+b[5]*40+b[8]*800
      x3 <-- 0
      x4 <-- b[6]*90+b[5]*40+b[8]*800
      x5 <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s =4  ΤΟΤΕ
    x1 <-- b[1]*130+b[2]*70+b[8]*800
    x2 <-- 0
    x3 <-- b[6]*90+b[5]*40+b[8]*800
    x4 <-- 0
    x5 <-- 0
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Αρχαία Ελληνικά Κατεύθυνσης είναι : ', b[1]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Νεοελληνική Λογοτεχνία Κατεύθυνσης είναι : ', b[2]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Λατινικά Κατεύθυνσης είναι : ', b[3]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στην Ιστορία Κατεύθυνσης είναι : ', b[4]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Νεοελληνική Γλώσσα Γενικής Παιδείας είναι : ', b[5]
  ΑΝ s=1  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στην Ιστορία Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=2  ΤΟΤΕ
    ΑΝ s1=1  ΤΟΤΕ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στις Αρχές Οικονομικής Θεωρίας είναι : ', b[7]
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s=3  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Φυσική Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=4  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Βιολογία Γενικής Παιδείας είναι : ', b[6]
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ thetikh(x1,x2,x3,x4,x5)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: s,s1
  ΠΡΑΓΜΑΤΙΚΕΣ: a[7,4],b[8],temp,x1,x2,x3,x4,x5
ΑΡΧΗ
  s1 <-- 0
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α','τετράμηνο στη Βιολογία Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B','τετράμηνο στη Βιολογία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[1,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Βιολογία Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Χημεία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[2,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Χημεία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[2,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Χημεία Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[2,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στα Μαθηματικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στα Μαθηματικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Μαθηματικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Φυσική Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[4,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Φυσική Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[4,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Φυσική Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[4,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Νεολληνική Γλώσσα '
  ΔΙΑΒΑΣΕ a[5,3]
  ΓΡΑΨΕ ' Παρακαλώ διαλέξτε ποιο μάθημα Γενικής Παιδείας εξετάζεστε σε Πανελλαδικό Επίπεδο '
  ΓΡΑΨΕ ' 1. Ιστορία Γενικής Παιδείας '
  ΓΡΑΨΕ ' 2. Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
  ΓΡΑΨΕ ' 3. Φυσική Γενικής Παιδείας '
  ΓΡΑΨΕ ' 4. Βιολογία Γενικής Παιδείας '
  ΔΙΑΒΑΣΕ s
  ΑΝ s = 1  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στην Ιστορία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 2  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
    ΓΡΑΨΕ ' Δώσατε το επιλεγόμενο μάθημα Αρχές Οικονομικής Θεωρίας '
    ΓΡΑΨΕ ' 1. Ναι '
    ΓΡΑΨΕ ' 2. Όχι '
    ΔΙΑΒΑΣΕ s1
    ΑΝ s1 = 1  ΤΟΤΕ
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,1]
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας'
      ΔΙΑΒΑΣΕ a[7,2]
      ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,3]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s = 3  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Φυσική Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 4  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Βιολογία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ ' Δεν διαλέξατε κάποια έγκυρη επιλογή '
  ΤΕΛΟΣ_ΑΝ
  a[1,4] <-- (a[1,1]+a[1,2])/2
  temp <-- Α_Τ(a[1,4]-a[1,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[1,4]>a[1,3]  ΤΟΤΕ
      a[1,4] <-- a[1,3] + 2
    ΑΛΛΙΩΣ
      a[1,4] <-- a[1,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[1] <-- a[1,4] * 0.3 + a[1,3] * 0.7
  a[2,4] <-- (a[2,1]+a[2,2])/2
  temp <-- Α_Τ(a[2,4]-a[2,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[2,4]>a[2,3]  ΤΟΤΕ
      a[2,4] <-- a[2,3] + 2
    ΑΛΛΙΩΣ
      a[2,4] <-- a[2,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[2] <-- a[2,4] * 0.3 + a[2,3] * 0.7
  a[3,4] <-- (a[3,1]+a[3,2])/2
  temp <-- Α_Τ(a[3,4]-a[3,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[3,4]>a[3,3]  ΤΟΤΕ
      a[3,4] <-- a[3,3] + 2
    ΑΛΛΙΩΣ
      a[3,4] <-- a[3,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[3] <-- a[3,4] * 0.3 + a[3,3] * 0.7
  a[4,4] <-- (a[4,1]+a[4,2])/2
  temp <-- Α_Τ(a[4,4]-a[4,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[4,4]>a[4,3]  ΤΟΤΕ
      a[4,4] <-- a[4,3] + 2
    ΑΛΛΙΩΣ
      a[4,4] <-- a[4,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[4] <-- a[4,4] * 0.3 + a[4,3] * 0.7
  a[5,4] <-- (a[5,1]+a[5,2])/2
  temp <-- Α_Τ(a[5,4]-a[5,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[5,4]>a[5,3]  ΤΟΤΕ
      a[5,4] <-- a[5,3] + 2
    ΑΛΛΙΩΣ
      a[5,4] <-- a[5,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[5] <-- a[5,4] * 0.3 + a[5,3] * 0.7
  a[6,4] <-- (a[6,1]+a[6,2])/2
  temp <-- Α_Τ(a[6,4]-a[6,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[6,4]>a[6,3]  ΤΟΤΕ
      a[6,4] <-- a[6,3] + 2
    ΑΛΛΙΩΣ
      a[6,4] <-- a[6,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[6] <-- a[6,4] * 0.3 + a[6,3] * 0.7
  ΑΝ s1 = 1  ΤΟΤΕ
    a[7,4] <-- (a[7,1]+a[7,2])/2
    temp <-- Α_Τ(a[7,4]-a[7,3])
    ΑΝ  temp > 2  ΤΟΤΕ
      ΑΝ  a[7,4]>a[7,3]  ΤΟΤΕ
        a[7,4] <-- a[7,3] + 2
      ΑΛΛΙΩΣ
        a[7,4] <-- a[7,3] - 2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    b[7] <-- a[7,4] * 0.3 + a[7,3] * 0.7
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6]+b[7])/7
  ΑΛΛΙΩΣ
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6])/6
  ΤΕΛΟΣ_ΑΝ
  ΑΝ s = 1 ΤΟΤΕ
    x1 <-- b[5]*90+b[6]*40+b[8]*800
    x2 <-- 0
    x3 <-- b[1]*130+b[2]*70+b[8]*800
    x4 <-- 0
    x5 <-- 0
  ΑΛΛΙΩΣ_ΑΝ s = 2 ΤΟΤΕ
    ΑΝ s1 = 1  ΤΟΤΕ
      x1 <-- 0
      x2 <-- b[6]*90+b[5]*40+b[8]*800
      x3 <-- b[1]*130+b[2]*70+b[8]*800
      x4 <-- b[6]*90+b[5]*40+b[8]*800
      x5 <-- b[7]*130+b[6]*70+b[8]*800
    ΑΛΛΙΩΣ
      x1 <-- 0
      x2 <-- b[6]*90+b[5]*40+b[8]*800
      x3 <-- b[1]*130+b[2]*70+b[8]*800
      x4 <-- b[6]*90+b[5]*40+b[8]*800
      x5 <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s =4 Η s=3 ΤΟΤΕ
    x1 <-- 0
    x2 <-- 0
    x3 <-- b[1]*130+b[2]*70+b[8]*800
    x4 <-- 0
    x5 <-- 0
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Βιολογία Κατεύθυνσης είναι : ', b[1]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Χημεία Κατεύθυνσης είναι : ', b[2]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά Κατεύθυνσης είναι : ', b[3]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Φυσική Κατεύθυνσης είναι : ', b[4]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Νεοελληνική Γλώσσα Γενικής Παιδείας είναι : ', b[5]
  ΑΝ s=1  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στην Ιστορία Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=2  ΤΟΤΕ
    ΑΝ s1=1  ΤΟΤΕ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στις Αρχές Οικονομικής Θεωρίας είναι : ', b[7]
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s=3  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Φυσική Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=4  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Βιολογία Γενικής Παιδείας είναι : ', b[6]
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ texnologikh_1(x1,x2,x3,x4,x5)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: s,s1
  ΠΡΑΓΜΑΤΙΚΕΣ: a[7,4],b[8],temp,x1,x2,x3,x4,x5
ΑΡΧΗ
  s1 <-- 0
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α','τετράμηνο στα Μαθηματικά Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B','τετράμηνο στα Μαθηματικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[1,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Μαθηματικά Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Φυσική Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[2,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Φυσική Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[2,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Φυσική Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[2,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στην Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον '
  ΔΙΑΒΑΣΕ a[3,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στην Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον '
  ΔΙΑΒΑΣΕ a[3,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στην Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον '
  ΔΙΑΒΑΣΕ a[3,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στις Αρχές Οργάνωσης και Διοίκησης Επιχειρήσεων και Υπηρεσιών '
  ΔΙΑΒΑΣΕ a[4,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στις Αρχές Οργάνωσης και Διοίκησης Επιχειρήσεων και Υπηρεσιών '
  ΔΙΑΒΑΣΕ a[4,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στις Αρχές Οργάνωσης και Διοίκησης Επιχειρήσεων και Υπηρεσιών '
  ΔΙΑΒΑΣΕ a[4,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Νεολληνική Γλώσσα '
  ΔΙΑΒΑΣΕ a[5,3]
  ΓΡΑΨΕ ' Παρακαλώ διαλέξτε ποιο μάθημα Γενικής Παιδείας εξετάζεστε σε Πανελλαδικό Επίπεδο '
  ΓΡΑΨΕ ' 1. Ιστορία Γενικής Παιδείας '
  ΓΡΑΨΕ ' 2. Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
  ΓΡΑΨΕ ' 3. Φυσική Γενικής Παιδείας '
  ΓΡΑΨΕ ' 4. Βιολογία Γενικής Παιδείας '
  ΔΙΑΒΑΣΕ s
  ΑΝ s = 1  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στην Ιστορία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 2  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
    ΓΡΑΨΕ ' Δώσατε το επιλεγόμενο μάθημα Αρχές Οικονομικής Θεωρίας '
    ΓΡΑΨΕ ' 1. Ναι '
    ΓΡΑΨΕ ' 2. Όχι '
    ΔΙΑΒΑΣΕ s1
    ΑΝ s1 = 1  ΤΟΤΕ
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,1]
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας'
      ΔΙΑΒΑΣΕ a[7,2]
      ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,3]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s = 3  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Φυσική Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 4  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Βιολογία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ ' Δεν διαλέξατε κάποια έγκυρη επιλογή '
  ΤΕΛΟΣ_ΑΝ
  a[1,4] <-- (a[1,1]+a[1,2])/2
  temp <-- Α_Τ(a[1,4]-a[1,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[1,4]>a[1,3]  ΤΟΤΕ
      a[1,4] <-- a[1,3] + 2
    ΑΛΛΙΩΣ
      a[1,4] <-- a[1,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[1] <-- a[1,4] * 0.3 + a[1,3] * 0.7
  a[2,4] <-- (a[2,1]+a[2,2])/2
  temp <-- Α_Τ(a[2,4]-a[2,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[2,4]>a[2,3]  ΤΟΤΕ
      a[2,4] <-- a[2,3] + 2
    ΑΛΛΙΩΣ
      a[2,4] <-- a[2,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[2] <-- a[2,4] * 0.3 + a[2,3] * 0.7
  a[3,4] <-- (a[3,1]+a[3,2])/2
  temp <-- Α_Τ(a[3,4]-a[3,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[3,4]>a[3,3]  ΤΟΤΕ
      a[3,4] <-- a[3,3] + 2
    ΑΛΛΙΩΣ
      a[3,4] <-- a[3,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[3] <-- a[3,4] * 0.3 + a[3,3] * 0.7
  a[4,4] <-- (a[4,1]+a[4,2])/2
  temp <-- Α_Τ(a[4,4]-a[4,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[4,4]>a[4,3]  ΤΟΤΕ
      a[4,4] <-- a[4,3] + 2
    ΑΛΛΙΩΣ
      a[4,4] <-- a[4,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[4] <-- a[4,4] * 0.3 + a[4,3] * 0.7
  a[5,4] <-- (a[5,1]+a[5,2])/2
  temp <-- Α_Τ(a[5,4]-a[5,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[5,4]>a[5,3]  ΤΟΤΕ
      a[5,4] <-- a[5,3] + 2
    ΑΛΛΙΩΣ
      a[5,4] <-- a[5,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[5] <-- a[5,4] * 0.3 + a[5,3] * 0.7
  a[6,4] <-- (a[6,1]+a[6,2])/2
  temp <-- Α_Τ(a[6,4]-a[6,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[6,4]>a[6,3]  ΤΟΤΕ
      a[6,4] <-- a[6,3] + 2
    ΑΛΛΙΩΣ
      a[6,4] <-- a[6,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[6] <-- a[6,4] * 0.3 + a[6,3] * 0.7
  ΑΝ s1 = 1  ΤΟΤΕ
    a[7,4] <-- (a[7,1]+a[7,2])/2
    temp <-- Α_Τ(a[7,4]-a[7,3])
    ΑΝ  temp > 2  ΤΟΤΕ
      ΑΝ  a[7,4]>a[7,3]  ΤΟΤΕ
        a[7,4] <-- a[7,3] + 2
      ΑΛΛΙΩΣ
        a[7,4] <-- a[7,3] - 2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    b[7] <-- a[7,4] * 0.3 + a[7,3] * 0.7
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6]+b[7])/7
  ΑΛΛΙΩΣ
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6])/6
  ΤΕΛΟΣ_ΑΝ
  ΑΝ s = 1 ΤΟΤΕ
    x1 <-- b[5]*90+b[6]*40+b[8]*800
    x2 <-- b[1]*130+b[2]*90+b[8]*800
    x3 <-- 0
    x4 <-- b[1]*130+b[2]*90+b[8]*800
    x5 <-- 0
  ΑΛΛΙΩΣ_ΑΝ s = 2 ΤΟΤΕ
    ΑΝ s1 = 1  ΤΟΤΕ
      x1 <-- 0
      x2 <-- b[1]*130+b[2]*90+b[8]*800
      x3 <-- 0
      x4 <-- b[1]*130+b[2]*90+b[8]*800
      x5 <-- b[7]*130+b[6]*70+b[8]*800
    ΑΛΛΙΩΣ
      x1 <-- 0
      x2 <-- b[1]*130+b[2]*90+b[8]*800
      x3 <-- 0
      x4 <-- b[1]*130+b[2]*90+b[8]*800
      x5 <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s =4 ΤΟΤΕ
    x1 <-- 0
    x2 <-- b[1]*130+b[2]*90+b[8]*800
    x3 <-- b[6]*90+b[5]*40+b[8]*800
    x4 <-- b[1]*130+b[2]*90+b[8]*800
    x5 <-- 0
  ΑΛΛΙΩΣ_ΑΝ s =3 ΤΟΤΕ
    x1 <-- 0
    x2 <-- b[1]*130+b[2]*90+b[8]*800
    x3 <-- 0
    x4 <-- b[1]*130+b[2]*90+b[8]*800
    x5 <-- 0
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά Κατεύθυνσης είναι : ', b[1]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Φυσική Κατεύθυνσης είναι : ', b[2]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στην Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον είναι : ', b[3]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στις Αρχές Οργάνωσης και Διοίκησης Επιχειρήσεων και Υπηρεσιών είναι : ', b[4]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Νεοελληνική Γλώσσα Γενικής Παιδείας είναι : ', b[5]
  ΑΝ s=1  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στην Ιστορία Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=2  ΤΟΤΕ
    ΑΝ s1=1  ΤΟΤΕ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στις Αρχές Οικονομικής Θεωρίας είναι : ', b[7]
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s=3  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Φυσική Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=4  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Βιολογία Γενικής Παιδείας είναι : ', b[6]
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ texnologikh_2(x1,x2,x3,x4,x5)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: s,s1
  ΠΡΑΓΜΑΤΙΚΕΣ: a[7,4],b[8],temp,x1,x2,x3,x4,x5
ΑΡΧΗ
  s1 <-- 0
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α','τετράμηνο στα Μαθηματικά Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B','τετράμηνο στα Μαθηματικά Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[1,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα  Μαθηματικά Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[1,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Φυσική Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[2,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Φυσική Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[2,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Φυσική Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[2,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Χημεία-Βιοχημεία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Χημεία-Βιοχημεία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Χημεία-Βιοχημεία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[3,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στην Ηλεκτρολογία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[4,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στην Ηλεκτρολογία Κατεύθυνσης'
  ΔΙΑΒΑΣΕ a[4,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στην Ηλεκτρολογία Κατεύθυνσης '
  ΔΙΑΒΑΣΕ a[4,3]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,1]
  ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Νεολληνική Γλώσσα'
  ΔΙΑΒΑΣΕ a[5,2]
  ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Νεολληνική Γλώσσα '
  ΔΙΑΒΑΣΕ a[5,3]
  ΓΡΑΨΕ ' Παρακαλώ διαλέξτε ποιο μάθημα Γενικής Παιδείας εξετάζεστε σε Πανελλαδικό Επίπεδο '
  ΓΡΑΨΕ ' 1. Ιστορία Γενικής Παιδείας '
  ΓΡΑΨΕ ' 2. Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
  ΓΡΑΨΕ ' 3. Φυσική Γενικής Παιδείας '
  ΓΡΑΨΕ ' 4. Βιολογία Γενικής Παιδείας '
  ΔΙΑΒΑΣΕ s
  ΑΝ s = 1  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στην Ιστορία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στην Ιστορία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 2  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
    ΓΡΑΨΕ ' Δώσατε το επιλεγόμενο μάθημα Αρχές Οικονομικής Θεωρίας '
    ΓΡΑΨΕ ' 1. Ναι '
    ΓΡΑΨΕ ' 2. Όχι '
    ΔΙΑΒΑΣΕ s1
    ΑΝ s1 = 1  ΤΟΤΕ
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,1]
      ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στις Αρχές Οικονομικής Θεωρίας'
      ΔΙΑΒΑΣΕ a[7,2]
      ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στις Αρχές Οικονομικής Θεωρίας '
      ΔΙΑΒΑΣΕ a[7,3]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s = 3  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Φυσική Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Φυσική Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ_ΑΝ s = 4  ΤΟΤΕ
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο Α',' τετράμηνο στη Βιολογία Γενικής Παιδείας'
    ΔΙΑΒΑΣΕ a[6,1]
    ΓΡΑΨΕ ' Δώστε τον προφορικό βαθμό που πήρατε στο B',' τετράμηνο στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,2]
    ΓΡΑΨΕ ' Δώστε το γραπτό βαθμό που πήρατε στις εξετάσεις στη Βιολογία Γενικής Παιδείας '
    ΔΙΑΒΑΣΕ a[6,3]
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ ' Δεν διαλέξατε κάποια έγκυρη επιλογή '
  ΤΕΛΟΣ_ΑΝ
  a[1,4] <-- (a[1,1]+a[1,2])/2
  temp <-- Α_Τ(a[1,4]-a[1,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[1,4]>a[1,3]  ΤΟΤΕ
      a[1,4] <-- a[1,3] + 2
    ΑΛΛΙΩΣ
      a[1,4] <-- a[1,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[1] <-- a[1,4] * 0.3 + a[1,3] * 0.7
  a[2,4] <-- (a[2,1]+a[2,2])/2
  temp <-- Α_Τ(a[2,4]-a[2,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[2,4]>a[2,3]  ΤΟΤΕ
      a[2,4] <-- a[2,3] + 2
    ΑΛΛΙΩΣ
      a[2,4] <-- a[2,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[2] <-- a[2,4] * 0.3 + a[2,3] * 0.7
  a[3,4] <-- (a[3,1]+a[3,2])/2
  temp <-- Α_Τ(a[3,4]-a[3,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[3,4]>a[3,3]  ΤΟΤΕ
      a[3,4] <-- a[3,3] + 2
    ΑΛΛΙΩΣ
      a[3,4] <-- a[3,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[3] <-- a[3,4] * 0.3 + a[3,3] * 0.7
  a[4,4] <-- (a[4,1]+a[4,2])/2
  temp <-- Α_Τ(a[4,4]-a[4,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[4,4]>a[4,3]  ΤΟΤΕ
      a[4,4] <-- a[4,3] + 2
    ΑΛΛΙΩΣ
      a[4,4] <-- a[4,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[4] <-- a[4,4] * 0.3 + a[4,3] * 0.7
  a[5,4] <-- (a[5,1]+a[5,2])/2
  temp <-- Α_Τ(a[5,4]-a[5,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[5,4]>a[5,3]  ΤΟΤΕ
      a[5,4] <-- a[5,3] + 2
    ΑΛΛΙΩΣ
      a[5,4] <-- a[5,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[5] <-- a[5,4] * 0.3 + a[5,3] * 0.7
  a[6,4] <-- (a[6,1]+a[6,2])/2
  temp <-- Α_Τ(a[6,4]-a[6,3])
  ΑΝ  temp > 2  ΤΟΤΕ
    ΑΝ  a[6,4]>a[6,3]  ΤΟΤΕ
      a[6,4] <-- a[6,3] + 2
    ΑΛΛΙΩΣ
      a[6,4] <-- a[6,3] - 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  b[6] <-- a[6,4] * 0.3 + a[6,3] * 0.7
  ΑΝ s1 = 1  ΤΟΤΕ
    a[7,4] <-- (a[7,1]+a[7,2])/2
    temp <-- Α_Τ(a[7,4]-a[7,3])
    ΑΝ  temp > 2  ΤΟΤΕ
      ΑΝ  a[7,4]>a[7,3]  ΤΟΤΕ
        a[7,4] <-- a[7,3] + 2
      ΑΛΛΙΩΣ
        a[7,4] <-- a[7,3] - 2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    b[7] <-- a[7,4] * 0.3 + a[7,3] * 0.7
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6]+b[7])/7
  ΑΛΛΙΩΣ
    b[8] <-- (b[1]+b[2]+b[3]+b[4]+b[5]+b[6])/6
  ΤΕΛΟΣ_ΑΝ
  ΑΝ s = 1 ΤΟΤΕ
    x1 <-- b[5]*90+b[6]*40+b[8]*800
    x2 <-- b[1]*130+b[2]*90+b[8]*800
    x3 <-- 0
    x4 <-- b[1]*130+b[2]*90+b[8]*800
    x5 <-- 0
  ΑΛΛΙΩΣ_ΑΝ s = 2 ΤΟΤΕ
    ΑΝ s1 = 1  ΤΟΤΕ
      x1 <-- 0
      x2 <-- b[1]*130+b[2]*90+b[8]*800
      x3 <-- 0
      x4 <-- b[1]*130+b[2]*90+b[8]*800
      x5 <-- b[7]*130+b[6]*70+b[8]*800
    ΑΛΛΙΩΣ
      x1 <-- 0
      x2 <-- b[1]*130+b[2]*90+b[8]*800
      x3 <-- 0
      x4 <-- b[1]*130+b[2]*90+b[8]*800
      x5 <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s =4 ΤΟΤΕ
    x1 <-- 0
    x2 <-- b[1]*130+b[2]*90+b[8]*800
    x3 <-- b[6]*90+b[5]*40+b[8]*800
    x4 <-- b[1]*130+b[2]*90+b[8]*800
    x5 <-- 0
  ΑΛΛΙΩΣ_ΑΝ s =3 ΤΟΤΕ
    x1 <-- 0
    x2 <-- b[1]*130+b[2]*90+b[8]*800
    x3 <-- 0
    x4 <-- b[1]*130+b[2]*90+b[8]*800
    x5 <-- 0
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά Κατεύθυνσης είναι : ', b[1]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Φυσική Κατεύθυνσης είναι : ', b[2]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Χημεία-Βιοχημεία Κατεύθυνσης είναι : ', b[3]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στην Ηλεκτρολογία Κατεύθυνσης είναι : ', b[4]
  ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Νεοελληνική Γλώσσα Γενικής Παιδείας είναι : ', b[5]
  ΑΝ s=1  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στην Ιστορία Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=2  ΤΟΤΕ
    ΑΝ s1=1  ΤΟΤΕ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στις Αρχές Οικονομικής Θεωρίας είναι : ', b[7]
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στα Μαθηματικά & Στοιχεία Στατιστικής Γενικής Παιδείας είναι : ', b[6]
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ s=3  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Φυσική Γενικής Παιδείας είναι : ', b[6]
  ΑΛΛΙΩΣ_ΑΝ s=4  ΤΟΤΕ
    ΓΡΑΨΕ 'Ο Βαθμός που πήρατε στη Βιολογία Γενικής Παιδείας είναι : ', b[6]
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 

Ελπίζω να μην έχει εκτελέσιμα λάθη. Ορθογραφικά ελπίζω πως όχι. Εάν έχετε κάποια ιδέα για κάποια καινούρια προσθήκη είναι ευπρόσδεκτη.


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 24 Ιουν 2008 08:04 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 21 Ιαν 2008 12:51 am
Δημοσιεύσεις: 3
Χρησιμοποίησα το συγκεκριμένο πρόγραμμα για να υπολογίσω τα μόρια που συγκέντρωσα
στο 4ο επιστημονικό πεδίο. Στη συνέχεια χρησιμοποίησα τον τύπο που βρήκα σε ένα φυλλάδιο φροντιστηρίου που αναφέρεται στον υπολογισμό μορίων και ισχύει για κάθε πεδίο. Είναι ο εξής:

(ΓΒΠ x 8 + ΜΑΘ1ΒΑΡ x 1.3 + ΜΑΘ2ΒΑΡ x 0.7) x 100 = ΜΟΡΙΑ

Όμως, όταν υπολογίζω τα μόρια με το πρόγραμμα, μου βγαίνουν 200 περισσότερα. Αντιμετωπίζει κάποιος άλλος το ίδιο πρόβλημα?


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 24 Ιουν 2008 09:09 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
exeis valei tous proforikous vathmous sto ypologismo ton vathmon tou kathe mathimatos???


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters