Τώρα είναι Τρί 31 Μαρ 2020 10:43 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 04 Ιουν 2007 09:06 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 03 Ιουν 2007 05:11 pm
Δημοσιεύσεις: 3
Τοποθεσία: Χανιά
Έφτιαξα ένα calculator, του οποίου η λειτουργία σταματά μόνο όταν ο χρήστης το σταματήσει χειροκίνητα, ή οταν γράψει αντί για 'ΠΡΟΣΘΕΣΗ', 'ΑΦΑΙΡΕΣΗ', 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ή 'ΔΙΑΙΡΕΣΗ', δύο φορές κάτι άλλο (την πρώτη φορά θα ζητήσει να πληκτρολογήσετε ξανά, αλλά την δεύτερη θα σταματήσει).

Εδώ έχουμε 4 διαδικασίες, τις οποίες καλεί το πρόγραμμα ανάλογα με το τι πράξη δηλώσαμε ότι θέλουμε να πραγματοποιήσουμε. Κάθε διαδικασία αντιπροσωπεύει και μια πράξη. Για να γίνει το πρόγραμμα επαναλαμβανόμενο, έβαλα στο τέλος της κάθε διαδικασίας ξανά την ερώτηση για το τι πράξη θέλουμε να γίνει, και δήλωσα ξανά τα βήματα που πρέπει να ακολουθήσει το προγραμμα ανάλογα με αυτό που του γράψουμε.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Κομπιουτεράκι

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΑΞΗ

ΑΡΧΗ

  ΓΡΑΨΕ 'Αν θέλετε να προσθέσετε πληκρολογήστε ΠΡΟΣΘΕΣΗ, αν θέλετε να αφαιρέσετε ΑΦΑΙΡΕΣΗ, αν θέλετε να πολλαπλασιάσετε ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ και αν θέλετε να διαιρέσετε ΔΙΑΙΡΕΣΗ'
  ΔΙΑΒΑΣΕ  ΠΡΑΞΗ
  ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΑΦΑΙΡΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
    ΚΑΛΕΣΕ ΔΙΑΙΡΩ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν καταλαβαίνω. Πληκρολογήστε ξανά'
    ΔΙΑΒΑΣΕ ΠΡΑΞΗ
    ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΦΑΙΡΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
      ΚΑΛΕΣΕ ΔΙΑΙΡΩ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΘΕΤΩ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΑΞΗ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, ΑΠΟΤΕΛΕΣΜΑ1
ΑΡΧΗ
  ΓΡΑΨΕ 'Πληκτρολογήστε τον α'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'Πληκτρολογήστε το β'
  ΔΙΑΒΑΣΕ β
  ΑΠΟΤΕΛΕΣΜΑ1 <-- α+β
  ΓΡΑΨΕ 'Το αποτέλεσμα είναι:',ΑΠΟΤΕΛΕΣΜΑ1
  ΓΡΑΨΕ 'Αν θέλετε να προσθέσετε πληκρολογήστε ΠΡΟΣΘΕΣΗ, αν θέλετε να αφαιρέσετε ΑΦΑΙΡΕΣΗ, αν θέλετε να πολλαπλασιάσετε ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ και αν θέλετε να διαιρέσετε ΔΙΑΙΡΕΣΗ'
  ΔΙΑΒΑΣΕ  ΠΡΑΞΗ
  ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΑΦΑΙΡΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
    ΚΑΛΕΣΕ ΔΙΑΙΡΩ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν καταλαβαίνω. Πληκρολογήστε ξανά'
    ΔΙΑΒΑΣΕ ΠΡΑΞΗ
    ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΦΑΙΡΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
      ΚΑΛΕΣΕ ΔΙΑΙΡΩ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ ΑΦΑΙΡΩ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΑΞΗ
  ΠΡΑΓΜΑΤΙΚΕΣ: γ, δ, ΑΠΟΤΕΛΕΣΜΑ2
ΑΡΧΗ
  ΓΡΑΨΕ 'Πληκτρολογήστε τον α'
  ΔΙΑΒΑΣΕ γ
  ΓΡΑΨΕ 'Πληκτρολογήστε το β'
  ΔΙΑΒΑΣΕ δ
  ΑΠΟΤΕΛΕΣΜΑ2 <-- γ-δ
  ΓΡΑΨΕ 'Το αποτέλεσμα είναι:',ΑΠΟΤΕΛΕΣΜΑ2
  ΓΡΑΨΕ 'Αν θέλετε να προσθέσετε πληκρολογήστε ΠΡΟΣΘΕΣΗ, αν θέλετε να αφαιρέσετε ΑΦΑΙΡΕΣΗ, αν θέλετε να πολλαπλασιάσετε ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ και αν θέλετε να διαιρέσετε ΔΙΑΙΡΕΣΗ'
  ΔΙΑΒΑΣΕ  ΠΡΑΞΗ
  ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΑΦΑΙΡΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
    ΚΑΛΕΣΕ ΔΙΑΙΡΩ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν καταλαβαίνω. Πληκρολογήστε ξανά'
    ΔΙΑΒΑΣΕ ΠΡΑΞΗ
    ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΦΑΙΡΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
      ΚΑΛΕΣΕ ΔΙΑΙΡΩ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ ΠΟΛΛΑΠΛΑΣΙΑΖΩ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΑΞΗ
  ΠΡΑΓΜΑΤΙΚΕΣ: ζ, ι, ΑΠΟΤΕΛΕΣΜΑ3
ΑΡΧΗ
  ΓΡΑΨΕ 'Πληκτρολογήστε τον α'
  ΔΙΑΒΑΣΕ ζ
  ΓΡΑΨΕ 'Πληκτρολογήστε το β'
  ΔΙΑΒΑΣΕ ι
  ΑΠΟΤΕΛΕΣΜΑ3 <-- ζ*ι
  ΓΡΑΨΕ 'Το αποτέλεσμα είναι:',ΑΠΟΤΕΛΕΣΜΑ3
  ΓΡΑΨΕ 'Αν θέλετε να προσθέσετε πληκρολογήστε ΠΡΟΣΘΕΣΗ, αν θέλετε να αφαιρέσετε ΑΦΑΙΡΕΣΗ, αν θέλετε να πολλαπλασιάσετε ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ και αν θέλετε να διαιρέσετε ΔΙΑΙΡΕΣΗ'
  ΔΙΑΒΑΣΕ  ΠΡΑΞΗ
  ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΑΦΑΙΡΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
    ΚΑΛΕΣΕ ΔΙΑΙΡΩ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν καταλαβαίνω. Πληκρολογήστε ξανά'
    ΔΙΑΒΑΣΕ ΠΡΑΞΗ
    ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΦΑΙΡΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
      ΚΑΛΕΣΕ ΔΙΑΙΡΩ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΙΡΩ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΑΞΗ
  ΠΡΑΓΜΑΤΙΚΕΣ: κ, λ, ΑΠΟΤΕΛΕΣΜΑ4
ΑΡΧΗ
  ΓΡΑΨΕ 'Πληκτρολογήστε τον α'
  ΔΙΑΒΑΣΕ κ
  ΓΡΑΨΕ 'Πληκτρολογήστε το β'
  ΔΙΑΒΑΣΕ λ
  ΑΝ λ= 0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ο παρονομαστής της διαίρεσης είναι ίσος με μηδέν. Βάλτε άλλον'
    ΔΙΑΒΑΣΕ λ
    ΑΠΟΤΕΛΕΣΜΑ4 <-- κ/λ
    ΓΡΑΨΕ 'Το αποτέλεσμα είναι:',ΑΠΟΤΕΛΕΣΜΑ4
  ΑΛΛΙΩΣ
    ΑΠΟΤΕΛΕΣΜΑ4 <-- κ/λ
    ΓΡΑΨΕ 'Το αποτέλεσμα είναι:',ΑΠΟΤΕΛΕΣΜΑ4
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Αν θέλετε να προσθέσετε πληκρολογήστε ΠΡΟΣΘΕΣΗ, αν θέλετε να αφαιρέσετε ΑΦΑΙΡΕΣΗ, αν θέλετε να πολλαπλασιάσετε ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ και αν θέλετε να διαιρέσετε ΔΙΑΙΡΕΣΗ'
  ΔΙΑΒΑΣΕ  ΠΡΑΞΗ
  ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΑΦΑΙΡΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
    ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

  ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
    ΚΑΛΕΣΕ ΔΙΑΙΡΩ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν καταλαβαίνω. Πληκρολογήστε ξανά'
    ΔΙΑΒΑΣΕ ΠΡΑΞΗ
    ΑΝ ΠΡΑΞΗ= 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΤΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΦΑΙΡΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΟΛΛΑΠΛΑΣΙΑΖΩ

    ΑΛΛΙΩΣ_ΑΝ ΠΡΑΞΗ= 'ΔΙΑΙΡΕΣΗ'  ΤΟΤΕ
      ΚΑΛΕΣΕ ΔΙΑΙΡΩ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


Ίσως παρατηρήσετε ότι είναι λίγο μεγάλος ο κώδικας σε σχέση με αυτό που κάνει το πρόγραμμα. Αν δείτε ότι υπάρχουν κάποια περιττά πράγματα, πείτε μου το παρακαλώ.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters