Τώρα είναι Κυρ 05 Ιούλ 2020 09:49 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Συγχώνευση πινάκων
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 07:52 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! = ΤΕΛ14 =================================================================
! Σε κάποιο νομό υπάρχουν 4 αθλητικά σωματεία στίβου με ονόματα ΕΡΜΗΣ, ΝΙΚΗ,
! ΘΥΕΛΛΑ, ΑΣΤΕΡΑΣ. Κάθε σωματείο διαθέτει 40 αθλητές ενώ τη φετινή χρονιά
! προκρίνονται μόνο 25 αθλητές από το νομό για το πανελλήνιο πρωτάθλημα και
! θα είναι αυτοί με τη μεγαλύτερη επίδοση.
! Να αναπτύξετε πρόγραμμα που:
!  i. θα διαβάζει για κάθε σωματείο : το όνομα κάθε αθλητή και την επίδοση
!     του και θα τα τοποθετεί σε κατάλληλους πίνακες.
! ii. θα εκτυπώνει το όνομα, το σωματείο και την επίδοση των αθλητών που
!     προκρίθηκαν στο πανελλήνιο πρωτάθλημα με φθίνουσα διάταξη.
! ΠΑΡΑΤΗΡΗΣΗ :
! Για το ερώτημα i, να χρησιμοποιηθεί υποπρόγραμμα με όνομα Εισαγωγή_Ομάδας
! η οποία θα ζητά 40 ονόματα και 40 πραγματικούς αριθμούς και θα τα τοποθε-
! τεί σε αντίστοιχους πίνακες.
! Για το ερώτημα ii, να συνενωθούν κατάλληλα οι πίνακες σε ένα ζεύγος
! πινάκων 160 θέσεων.
! =========================================================================
!
ΠΡΟΓΡΑΜΜΑ TEL14
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j
  ΠΡΑΓΜΑΤΙΚΕΣ : επ1[40] , επ2[40] , επ3[40] ,  επ4[40] , επ[160] , temp2
  ΧΑΡΑΚΤΗΡΕΣ : name1[40] , name2[40] , name3[40] , name4[40] , name[160] , σωμ[160] , temp1
ΑΡΧΗ
  ΓΡΑΨΕ 'ΟΜΑΔΑ ΕΡΜΗΣ'
  ΚΑΛΕΣΕ Εισαγωγή_Ομάδας(name1,επ1)
  ΓΡΑΨΕ 'ΟΜΑΔΑ ΝΙΚΗ'
  ΚΑΛΕΣΕ Εισαγωγή_Ομάδας(name2,επ2)
  ΓΡΑΨΕ 'ΟΜΑΔΑ ΘΥΕΛΛΑ'
  ΚΑΛΕΣΕ Εισαγωγή_Ομάδας(name3,επ3)
  ΓΡΑΨΕ 'ΟΜΑΔΑ ΑΣΤΕΡΑΣ'
  ΚΑΛΕΣΕ Εισαγωγή_Ομάδας(name4,επ4)
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 40
    name[i] <-- name1[i]
    name[40+i] <-- name2[i]
    name[80+i] <-- name3[i]
    name[120+i] <-- name4[i]
    επ[i] <-- επ1[i]
    επ[40+i] <-- επ2[i]
    επ[80+i] <-- επ3[i]
    επ[120+i] <-- επ4[i]
    σωμ[i] <-- 'ΕΡΜΗΣ'
    σωμ[40+i] <-- 'ΝΙΚΗ'
    σωμ[80+i] <-- 'ΘΥΕΛΛΑ'
    σωμ[120+i] <-- 'ΑΣΤΕΡΑΣ'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 160
    ΓΙΑ j ΑΠΟ 160 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ επ[j-1] < επ[j] ΤΟΤΕ
        temp1 <-- name[j-1]
        name[j-1] <--  name[j]
        name[j] <-- temp1
        temp1 <-- σωμ[j-1]
        σωμ[j-1] <--  σωμ[j]
        σωμ[j] <-- temp1
        temp2 <-- επ[j-1]
        επ[j-1] <--  επ[j]
        επ[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Για το πανελλήνιο πρωτάθλημα προκρίνονται οι εξής αθλητές'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 25
    ΓΡΑΨΕ name[i] , σωμ[i] , επ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Εισαγωγή_Ομάδας(a,b)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i
  ΠΡΑΓΜΑΤΙΚΕΣ : b[40]
  ΧΑΡΑΚΤΗΡΕΣ : a[40]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 40
    ΓΡΑΨΕ 'Δώσε το όνομα του παίκτη Νο :',i
    ΔΙΑΒΑΣΕ a[i]
    ΓΡΑΨΕ 'Δώσε την επίδοσή του'
    ΔΙΑΒΑΣΕ b[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters