Τώρα είναι Τρί 31 Μαρ 2020 10:29 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Τι θα εμφανίσει;
ΔημοσίευσηΔημοσιεύτηκε: Παρ 23 Φεβ 2007 02:35 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Νοέμ 2003 01:11 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
! Με την βοήθεια του τμηματικού προγραμματισμού να γίνουν τα εξής:
! α)  Να δημιουργηθεί διαδικασία η οποία θα δέχεται δύο θετικούς ακέραιους
! αριθμούς και θα επιστρέφει: τον μικρότερο χωρίς αλλαγή, αλλά αντί για τον
! μεγαλύτερο θα επιστρέφει το πηλίκο της ακέραιας διαίρεσης του με το 2.
! β)  Να κατασκευαστεί κύριο πρόγραμμα το οποίο θα διαβάζει 2 θετικούς
! ακέραιους αριθμούς και έπειτα θα χρησιμοποιεί την παραπάνω διαδικασία
! συνεχώς, ανατροφοδοτώντας τη με τους αριθμούς που επιστρέφει, μέχρι
! κάποιος από τους αριθμούς αυτούς να γίνει μηδέν. Η εμφάνιση του
! προγράμματος θα είναι το πόσες φορές έγινε κλήση της διαδικασίας.

ΠΡΟΓΡΑΜΜΑ παραδειγμα_1
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,Π
ΑΡΧΗ
  ΓΡΑΨΕ'ΔΩΣΕ 2 ΑΡΙΘΜΟΥΣ'
  ΔΙΑΒΑΣΕ Α,Β
  Π <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΛΕΣΕ ΒΗΜΑ1(Α,Β)
    Π <-- Π+1
  ΜΕΧΡΙΣ_ΟΤΟΥ (Α=0) Η (Β=0)
  ΓΡΑΨΕ' Η ΚΛΗΣΗ ΤΗΣ ΔΙΑΔΙΚΑΣΙΑΣ ΕΓΙΝΕ:',Π,' ΦΟΡΕΣ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ ΒΗΜΑ1(Χ,Υ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ,Υ
ΑΡΧΗ
  ΑΝ Χ>Υ ΤΟΤΕ
    Χ <-- Χ DIV 2
  ΑΛΛΙΩΣ
    Υ <-- Υ DIV 2
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters