Τώρα είναι Κυρ 05 Ιούλ 2020 10:38 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 09 Νοέμ 2006 04:48 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 09 Νοέμ 2006 03:44 pm
Δημοσιεύσεις: 2
Τοποθεσία: SAMOS
ΓΕΙΑ ΣΑΣ. ΕΙΜΑΙ ΜΑΘΗΤΗΣ ΤΗΣ ΤΡΙΤΗΣ ΛΥΚΕΙΟΥ ΚΑΙ ΦΕΤΟΣ ΘΑ ΔΩΣΩ ΕΞΕΤΑΣΕΙΣ ΑΕΠΠ. ΕΦΤΙΑΞΑ ΑΥΤΟ ΤΟ ΑΠΛΟ ΠΡΟΓΡΑΜΜΑΤΑΚΙ ΠΟΥ ΥΠΟΛΟΓΙΖΕΙ ΤΙΣ ΡΙΖΕΣ ΤΗΣ ΔΕΥΤΕΡΟΒΑΘΜΙΑΣ ΕΞΙΣΩΣΗΣ αχ^2+βχ+γ=0 ΑΚΟΜΑ ΚΑΙ ΑΝ Η ΔΙΑΚΡΙΝΟΥΣΑ ΕΙΝΑΙ ΑΡΝΗΤΙΚΗ.ΣΧΟΛΙΑ-ΔΙΟΡΘΩΣΕΙΣ ΦΥΣΙΚΑ....(ΤΟ ΕΦΤΙΑΞΑ ΜΕ ΤΗΝ ΓΛΩΣΣΟΜΑΘΕΙΑ 8,5 ΟΠΟΥ ΤΡΕΧΕΙ ΚΑΝΟΝΙΚΑ)

:wink:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ δευτεροβάθμια_εξίσωση
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ
  ΧΑΡΑΚΤΗΡΕΣ: απαν
ΑΡΧΗ
  ΚΑΛΕΣΕ εισαγωγή
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '-----------------------------------------------------------------------'
    ΓΡΑΨΕ 'Δώστε το συντελεστή α'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Δώστε το συντελεστή β'
    ΔΙΑΒΑΣΕ β
    ΓΡΑΨΕ 'Δώστε το συντελεστή γ'
    ΔΙΑΒΑΣΕ γ
    ΚΑΛΕΣΕ  υπολογισμός_πραγματικων_ριζών(α,β,γ)
    ΓΡΑΨΕ '-----------------------------------------------------------------------'
    ΓΡΑΨΕ 'Θέλετε να λύσετε κι άλλη εξίσωση;'
    ΓΡΑΨΕ 'Πατήστε οποιοδήποτε πληκτρο για επομενη εξίσωση και q για τερματισμό του προγράμματος'
    ΔΙΑΒΑΣΕ απαν
  ΜΕΧΡΙΣ_ΟΤΟΥ απαν='q' Η απαν='Q'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  δευτεροβάθμια_εξίσωση

!--------------------------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ υπολογισμός_πραγματικων_ριζών(α,β,γ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ,Δ
ΑΡΧΗ                
  ΑΝ α<>0 ΤΟΤΕ
    Δ <-- β^2-4*α*γ
    ΓΡΑΨΕ 'Η διακρίνουσα είναι:'
    ΑΝ Δ>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει δυο πραγματικές ρίζες...'
      ΓΡΑΨΕ 'Τις:'
      ΓΡΑΨΕ 'ρ1=',(-β+ Τ_Ρ(Δ))/(2*α),'και'
      ΓΡΑΨΕ 'ρ2=',(-β- Τ_Ρ(Δ))/(2*α)
    ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει μια διπλή ρίζα...'
      ΓΡΑΨΕ 'Την:'
      ΑΝ -β/(2*α)=-0 ΤΟΤΕ
        ΓΡΑΨΕ 'ρ=0'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ρ=',-β/(2*α)
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ Δ<0 ΤΟΤΕ
      ΚΑΛΕΣΕ υπολογισμός_μιγαδικών_ριζών(α,β,γ,Δ)
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ β<>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η εξίσωση έχει μια πραγματική ρίζα...'
    ΓΡΑΨΕ 'Την:'
    ΑΝ (-γ)/β=-0 ΤΟΤΕ
      ΓΡΑΨΕ 'ρ=0'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ρ=',(-γ)/β
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ γ<>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η εξίσωση είναι αδύνατη'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Η εξίσωση ειναι αόριστη'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!--------------------------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ υπολογισμός_μιγαδικών_ριζών(α,β,γ,Δ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,β,γ,Δ,Π,Φ
  ΧΑΡΑΚΤΗΡΕΣ: i
ΑΡΧΗ
  ΓΡΑΨΕ 'Η εξίσωση έχει δυο μιγαδικές ρίζες...'
  i <-- 'i'
  Π <-- (-β)/(2*α)
  Φ <--  Τ_Ρ(-Δ)/(2*α)
  ΓΡΑΨΕ 'Τις:'
  ΓΡΑΨΕ 'ρ1=',Π,'+',Φ,i,'και'
  ΓΡΑΨΕ 'ρ2=',Π,'-',Φ,i
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ εισαγωγή
ΑΡΧΗ
  ΓΡΑΨΕ'****************************************************'
  ΓΡΑΨΕ'*Το πρόγραμμα αυτό λύνει την δευτεροβάθμια εξισωση *'
  ΓΡΑΨΕ'*αχ^2+βχ+γ=0 στο σύνολο των πραγματικών και των μι-*'
  ΓΡΑΨΕ'*γαδικών αριθμών ζητώντας τους πραγματικούς        *'
  ΓΡΑΨΕ'συντελεστές α,β,γ                                  *'
  ΓΡΑΨΕ'****************************************************'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Τελευταία επεξεργασία από LOUIS και Παρ 01 Δεκ 2006 12:16 am, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: ΠΡΟΣΕΧΕ ΤΙΣ ΠΑΡΕΝΘΕΣΕΙΣ!!
ΔημοσίευσηΔημοσιεύτηκε: Παρ 24 Νοέμ 2006 02:21 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Οκτ 2006 12:14 am
Δημοσιεύσεις: 1
ΠΑΡΑ ΠΟΛΥ ΚΑΛΟ ΠΡΟΓΡΑΜΜΑ!!

ΠΡΟΣΕΧΕ ΤΗΝ ΔΙΑΦΟΡΑ ΤΩΝ:

-β/2*α ΚΑΙ -β/(2*α)

ΔΩΣΕ ΓΙΑ ΠΑΡΑΔΕΙΓΜΑ ΩΣ ΕΙΣΟΔΟ ΤΙΣ ΤΙΜΕΣ
4,-4,1. ΕΝΩ Η ΛΥΣΗ ΕΙΝΑΙ ΔΙΠΛΗ ΡΙΖΑ ΤΗΝ ρ=1/2 ΕΜΦΑΝΙΖΕΙ ρ=8.
ΤΟ ΛΑΘΟΣ ΟΦΕΙΛΕΤΑΙ ΣΤΟ ΓΕΓΟΝΟΣ ΟΤΙ ΛΕΙΠΕΙ Η ΠΑΡΕΝΘΕΣΗ ΑΠΟ ΤΟΝ ΠΑΡΟΝΟΜΑΣΤΗ.

ΣΥΝΕΧΙΣΕ ΕΤΣΙ ΚΑΙ ΣΙΓΟΥΡΑ ΘΑ ΤΑ ΚΑΤΑΦΕΡΕΙΣ!
[/b]

_________________
ΜΑΘΗΜΑΤΙΚΟΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 01 Δεκ 2006 12:22 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 09 Νοέμ 2006 03:44 pm
Δημοσιεύσεις: 2
Τοποθεσία: SAMOS
ΕΥΧΑΡΙΣΤΩ ΓΙΑ ΤΗΝ ΠΑΡΑΤΗΡΗΣΗ ΣΟΥ ΦΙΛΕ SPYROS ΚΑΙ ΓΙΑ ΤΑ ΕΝΘΑΡΡΥΝΤΙΚΑ ΣΟΥ ΛΟΓΙΑ.. :D :) ΕΝΩ ΕΙΧΑ ΠΑΡΑΤΗΡΗΣΕΙ ΤΟ ΛΑΘΟΣ ΣΤΙΣ ΔΟΚΙΜΕΣ ΓΙΑ ΤΙΣ ΔΥΟ ΡΙΖΕΣ ΜΟΥ ΞΕΦΥΓΕ ΝΑ ΔΙΟΡΘΩΣΩ ΤΗ 'ΣΥΝΤΑΞΗ' ΤΗΣ ΠΡΑΞΗΣ ΓΙΑ ΤΗΝ ΔΙΠΛΗ ΡΙΖΑ. ΠΑΝΤΩΣ ΕΥΧΑΡΙΣΤΩ..... :wink: :wink: (Το πρόγραμμα παραπάνω είναι διορθωμένο ως προς το σφάλμα που επισημάνθηκε)


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters