Τώρα είναι Τρί 02 Ιουν 2020 07:53 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Επίλυση εξίσωσης αx+β=0
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:44 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ==================================================
! Να γίνει πρόγραμμα το οποίο:
! α) Να διαβάζει 2 πραγματικούς αριθμούς α, β.
! β) Να λύνει την εξίσωση αx+β=0.
! ΣΗΜΕΙΩΣΕΙΣ:
! - Η επίλυση της εξίσωσης να γίνεται με ΔΙΑΔΙΚΑΣΙΑ
!   της μορφής Επίλυση_εξίσωσης(α, β, x, είδος)
!   όπου:
!    α, β: Οι τιμές των συντελεστών της εξίσωσης
!          (είσοδοι ΔΙΑΔΙΚΑΣΙΑΣ)
!       χ: Η λύση της εξίσωσης (έξοδος ΔΙΑΔΙΚΑΣΙΑΣ)
!   είδος: ΑΚΕΡΑΙΑ μεταβλητή (έξοδος ΔΙΑΔΙΚΑΣΙΑΣ)
!          που περιγράφει το είδος της εξίσωσης ως
!          εξής:
!                1 = Η εξίσωση έχει μια λύση
!                2 = Η εξίσωση είναι ΑΟΡΙΣΤΗ
!                3 = Η εξίσωση είναι ΑΔΥΝΑΤΗ
! - Η εμφάνιση της τιμής του x (στο κυρίως              
!   πρόγραμμα) να γίνεται μόνο αν εξίσωση έχει μία
!   λύση. Αλλιώς να εμφανίζεται ενημερωτικό μήνυμα.
! ==================================================


ΠΡΟΓΡΑΜΜΑ Επίλυση_πρωτοβάθμιας_εξίσωσης

ΜΕΤΑΒΛΗΤΕΣ
   ΠΡΑΓΜΑΤΙΚΕΣ: α, β, x
   ΑΚΕΡΑΙΕΣ: είδος

ΑΡΧΗ

   ΓΡΑΨΕ 'Δώσε το συντελεστή α:'
   ΔΙΑΒΑΣΕ α
   ΓΡΑΨΕ 'Δώσε το συντελεστή β:'
   ΔΙΑΒΑΣΕ β

   ΚΑΛΕΣΕ Επίλυση_εξίσωσης(α, β, x, είδος)

   ΕΠΙΛΕΞΕ είδος
      ΠΕΡΙΠΤΩΣΗ 1
         ΓΡΑΨΕ 'Η εξίσωση έχει λύση την τιμή x=', x
      ΠΕΡΙΠΤΩΣΗ 2
         ΓΡΑΨΕ 'Η εξίσωση είναι ΑΟΡΙΣΤΗ'
      ΠΕΡΙΠΤΩΣΗ 3
         ΓΡΑΨΕ 'Η εξίσωση είναι ΑΔΥΝΑΤΗ'
   ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Επίλυση_πρωτοβάθμιας_εξίσωσης

!---------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ Επίλυση_εξίσωσης(α, β, x, είδος)
ΜΕΤΑΒΛΗΤΕΣ
   ΠΡΑΓΜΑΤΙΚΕΣ: α, β, x
   ΑΚΕΡΑΙΕΣ: είδος
ΑΡΧΗ
   ΑΝ α<>0 ΤΟΤΕ
      x <-- -β/α
      είδος <-- 1     ! Δηλ. η εξίσωση έχει μια λύση
   ΑΛΛΙΩΣ
      ΑΝ β=0 ΤΟΤΕ
         είδος <-- 2  ! Δηλ. η εξίσωση είναι αόριστη
      ΑΛΛΙΩΣ
         είδος <-- 3  ! Δηλ. η εξίσωση είναι αδύνατη
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!---------------------------------------------------
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters