Τώρα είναι Σάβ 15 Αύγ 2020 04:58 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ταξινόμηση φυσσαλίδας
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 11:06 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ===========================================================
! Να γίνει πρόγραμμα που να διαβάζει 10 ακεραίους αριθμούς
! τους οποίους θα αποθηκεύει σε έναν πίνακα Π. Στη συνέχεια
! να ταξινομεί αυτούς τους αριθμούς σε αύξουσα σειρά με τη
! μέθοδο της φυσσαλίδας.
! ΣΗΜΕΙΩΣΗ:
! - Η αντιμετάθεση που απαιτεί η μέθοδος να γίνεται με χρήση
!   ΔΙΑΔΙΚΑΣΙΑΣ.
! ===========================================================


ΠΡΟΓΡΑΜΜΑ Ταξινόμηση_φυσσαλίδας

ΣΤΑΘΕΡΕΣ
  Ν=10

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, Π[Ν]

ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'Δώσε το ', i,'ο στοιχείο του πίνακα:'
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ Π[j-1]>Π[j] ΤΟΤΕ
        ΚΑΛΕΣΕ Αντιμετάθεσε(Π[j-1][j])
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ακολουθεί ο πίνακας ταξινομημένος σε αύξουσα σειρά:'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ i,'ο στοιχείο: ', Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ταξινόμηση_φυσσαλίδας

!------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ Αντιμετάθεσε(αριθμός1, αριθμός2)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αριθμός1, αριθμός2, temp
ΑΡΧΗ
  temp <-- αριθμός1
  αριθμός1 <-- αριθμός2
  αριθμός2 <-- temp
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!------------------------------------------------------------
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters