Τώρα είναι Τρί 31 Μαρ 2020 11:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 14 Απρ 2006 09:14 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 21 Ιούλ 2005 10:34 am
Δημοσιεύσεις: 11
Τοποθεσία: ΚΑΣΤΟΡΙΑ
Να και μια άσκηση που κάποιος μαθητής (δε ξέρω αν ισχύει γενικότερα, πάντως πολλοί μαθητές σκέφτηκαν τη συνάρτηση) θα σκεφτόταν να επιλύσει με συνάρτηση (υπάρχει σχετικό post στο τμήμα των συναρτήσεων), λόγω του ότι εκτελούνται μαθηματικές πράξεις.
Εδώ όμως βλέπουμε μια περίπτωση όπου γίνεται χρήση διαδικασίας μιας και το επιστρεφόμενο αποτέλεσμα ΔΕΝ είναι μόνο ένα. Αποφεύγουμε λοιπόν τη χρήση δύο συναρτήσεων (μιας για εύρεση μέγιστου και μια για εύρεση ελάχιστου) συγγράφοντας μια διαδικασία που υπολογίζει και τα δύο.


Syntax: [ Download ] [ Hide ]
!Να γραφεί πρόγραμμα που θα διαβάζει 4 αριθμούς α, β, γ, δ και θα εντοπίζει τον μεγαλύτερο και μικρότερο από αυτούς.

ΠΡΟΓΡΑΜΜΑ ΜΕΓΙΣΤΟΣ_ΕΛΑΧΙΣΤΟΣ_ΤΕΣΣΑΡΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a,b,c,d,max,min
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε 4 ακέραιους αριθμους'
  ΔΙΑΒΑΣΕ a,b,c,d
  max <-- a
  min <-- a
  ΚΑΛΕΣΕ MAX_MIN(b,max,min)
  ΚΑΛΕΣΕ MAX_MIN(c,max,min)
  ΚΑΛΕΣΕ MAX_MIN(d,max,min)
  ΓΡΑΨΕ 'Ο μέγιστος είναι ο',max
  ΓΡΑΨΕ 'Ο ελάχιστος είναι ο',min
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ MAX_MIN(x,max,min)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x,max,min
ΑΡΧΗ
  ΑΝ x>max ΤΟΤΕ
    max <-- x
  ΑΛΛΙΩΣ_ΑΝ x<min ΤΟΤΕ
    min <-- x
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters