Τώρα είναι Τρί 31 Μαρ 2020 10:17 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Πίνακας τιμών
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 05 Μαρ 2005 12:17 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Δίνεται το παρακάτω πρόγραμμα. Να δημιουργήσετε τον πίνακα τιμών καθώς και το ποιο θα είναι το αποτέλεσμα της εντολής ΓΡΑΨΕ.

Πλήρης περιγραφή στο: http://users.kor.sch.gr/ptsiotakis/aepp ... s/ask4.pdf

Syntax: [ Download ] [ Hide ]

ΠΡΟΓΡΑΜΜΑ Πίνακας_Τιμών
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
  ΠΡΑΓΜΑΤΙΚΕΣ: γ
ΑΡΧΗ
  α <-- 2
  β <-- 855
  γ <-- 5
  ΟΣΟ (β >= γ) ΕΠΑΝΑΛΑΒΕ
    α <-- α + 2
    ΚΑΛΕΣΕ Υπολογισμοί(α, β, γ)
    ΓΡΑΨΕ α, β, γ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πίνακας_Τιμών
! =========================================
ΔΙΑΔΙΚΑΣΙΑ Υπολογισμοί (x, y, z)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x, y
  ΠΡΑΓΜΑΤΙΚΕΣ: z
ΑΡΧΗ
  y <-- y DIV x
  z <-- 2 * z + x
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 


Με εκτίμηση, Τσιωτάκης Παναγιώτης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters