Τώρα είναι Πέμ 04 Ιουν 2020 02:02 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Διάβασμα τμήματος πίνακα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:40 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =======================================================================
! Να γίνει πρόγραμμα που να ζητάει έναν ακέραιο αριθμό Ν από το 1 ως το
! 100. Στη συνέχεια να διαβάζει Ν τιμές τις οποίες θα αποθηκεύει στις Ν
! πρώτες θέσεις ενός πίνακα ακεραίων αριθμών 100 θέσεων.
! Αν στον αριθμό Ν δοθεί μη-έγκυρη τιμή, το πρόγραμμα να τον ξαναζητάει.
! ΣΗΜΕΙΩΣΗ:
! - Το διάβασμα των τιμών του πίνακα να γίνεται με ΔΙΑΔΙΚΑΣΙΑ.
! =======================================================================


ΠΡΟΓΡΑΜΜΑ Διάβασμα_τμήματος_πίνακα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[100], πλήθος

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Πόσα στοιχεία του πίνακα θέλεις να διαβαστούν (0<πλήθος<101);'
    ΔΙΑΒΑΣΕ πλήθος
  ΜΕΧΡΙΣ_ΟΤΟΥ (πλήθος>0) ΚΑΙ (πλήθος<101)

  ΚΑΛΕΣΕ Διάβασε_τμήμα_πίνακα(Α, πλήθος)

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Διάβασμα_τμήματος_πίνακα

!------------------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ Διάβασε_τμήμα_πίνακα(Π, Ν)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[100], Ν, i
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ_ 'ΔΩΣΕ ΤΟ ', i, 'ο στοιχείο του πίνακα: '
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!------------------------------------------------------------------------

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters