Τώρα είναι Πέμ 27 Ιουν 2019 04:07 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 02 Φεβ 2012 07:53 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 02 Φεβ 2012 06:22 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΠΛΟΠΟΙΗΣΗ_ΤΕΤΡΑΓΩΝΙΚΗΣ_ΡΙΖΑΣ

!Το πρόγραμμα διαβάζει ένα μη αρνητικό αριθμό Α και απλοποιεί την
!τετραγωνική του ρίζα.
!π.χ. αν το Α=8 επιστρέφει Τ_Ρ(8)=2*Τ_Ρ(2)

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, ΣΥΝΤ, ΥΠΟΡ, Κ, Β
ΑΡΧΗ
  ΚΑΛΕΣΕ ΔΙΑΒΑΣΕ_ΑΡΙΘΜΟ(Α)
  Β ← Α_Μ(Τ_Ρ(Α))
  ΑΝ Α = Β^2 ΤΟΤΕ
    ΓΡΑΨΕ "ΤετραγωνικήΡίζα(", Α, ")=", Β
  ΑΛΛΙΩΣ
    ΣΥΝΤ ← 1
    ΥΠΟΡ ← Α
    Κ ← 2
    ΟΣΟ Κ^2 <= ΥΠΟΡ ΕΠΑΝΑΛΑΒΕ
      ΑΝ ΥΠΟΡ MOD (Κ^2) = 0 ΤΟΤΕ
        ΣΥΝΤ ← ΣΥΝΤ*Κ
        ΥΠΟΡ ← ΥΠΟΡ DIV (Κ^2)
      ΑΛΛΙΩΣ
        Κ ← Κ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΥΝΤ = 1 ΤΟΤΕ
      ΓΡΑΨΕ "Η Τετραγωνική Ρίζα του ", Α, "  δεν απλοποιείτε"
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ "ΤετραγωνικήΡίζα(", Α, ")=", ΣΥΝΤ, "*ΤετραγωνικήΡίζα(", ΥΠΟΡ, ")"
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΒΑΣΕ_ΑΡΙΘΜΟ(ΑΡ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΡ
ΑΡΧΗ
  ΓΡΑΨΕ "Δώσε μη αρνητικό ακέραιο"
  ΔΙΑΒΑΣΕ ΑΡ
  ΟΣΟ ΑΡ < 0 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ "Ο αριθμός δεν πρέπει να είναι αρνητικός"
    ΔΙΑΒΑΣΕ ΑΡ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Παρατήρηση: Το πρόγραμμα αργεί αν δώσουμε ένα μεγάλο αριθμό ο οποίος δεν απλοποιείτε.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters