Τώρα είναι Πέμ 27 Ιουν 2019 03:06 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 06 Ιαν 2013 03:08 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 06 Ιαν 2013 03:02 pm
Δημοσιεύσεις: 1
Καλώ από το κυρίως πρόγραμμα μια διαδικασία στέλνοντας έναν πίνακα.
Η διαδικασία με βάση τον πίνακα αυτό δημιουργεί έναν νέο πίνακα (διαφορετικό όνομα) και θέλω να τον στέλνει στο κυρίως πρόγραμμα.
Παρακάτω είναι ο κώδικας μέχρι το σημείο που στέλνω στη διαδικασία τον πίνακα.
Δεν ξέρω πως θα επιστρέψω τον νέο πίνακα στο κυρίως πρόγραμμα.
Μπορείτε να βοηθήσετε?
Ευχαριστώ και Καλή Χρονιά.

Μέρος Κυρίως προγράμματος
Syntax: [ Download ] [ Hide ]
ΚΑΛΕΣΕ  DIAD(BATHMOS) !BATHMOS είναι πίνακας μονοδιάστατος με 30 θέσεις



Syntax: [ Download ] [ Hide ]
ΔΙΑΔΙΚΑΣΙΑ DIAD(NEOS)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Κ,NEOS[30]

ΑΡΧΗ
  Ι <-- 1
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 30
    ΑΝ BATHMOS[Κ]<50 ΤΟΤΕ
      NEOS[Ι] <-- BATHMOS[Κ]+5
      Ι <-- Ι+1
      ΤΕΛΟΣ_ΑΝ
     
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ NEOS !Εδώ δεν ξέρω τι να γράψω για να επιστρέψω τον πίνακα στο κυρίως πρόγραμμα
  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 08 Ιαν 2013 08:45 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Τη διαδικασία άλλαξέ την σε: DIAD(BATHMOS, NEOS)
Η 1η παράμετρος είναι ο πίνακας που θα παίρνει από το κύριο πρόγραμμα, ενώ η 2η ο πίνακας που θα επιστρέφει σε αυτό.
Το "ΓΡΑΨΕ NEOS" δεν χρειάζεται.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters