Τώρα είναι Δευτ 01 Ιουν 2020 07:27 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εθνική Ελλάδας μπάσκετ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 03 Απρ 2003 11:41 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ==================================================================================
! Η εθνική Ελλάδας στο μπάσκετ αποφάσισε να δώσει 3 φιλικούς αγώνες με μια ομάδα
! επιλέκτων του ΝΒΑ. Στην εθνική συμμετείχαν μόνο 5 παίκτες.
! Να γίνει πρόγραμμα το οποίο:
!   Α) Να ζητάει τους πόντους που πέτυχε ο κάθε παίκτης της εθνικής σε κάθε έναν από
!      τους 3 αγώνες.
!   Β) Να εμφανίζει ποιος από τους 5 είναι ο πολυτιμότερος παίκτης της διοργάνωσης
!      (MVP), δηλαδή ποιος πέτυχε το μεγαλύτερο σύνολο πόντων.
!   Γ) Να εμφανίζει ποιος από τους 3 ήταν ο χειρότερος αγώνας της εθνικής, δηλαδή σε
!      σε ποιόν η ομάδα πέτυχε τους λιγότερους πόντους.
! ==================================================================================


ΠΡΟΓΡΑΜΜΑ Εθνική_Ελλάδας_μπάσκετ

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πόντοι[5,3], πόντοι_παικτών[5], πόντοι_αγώνων[3]
  ΑΚΕΡΑΙΕΣ: παίκτης, αγώνας, MVP, χειρότερος_αγώνας, max, min

ΑΡΧΗ

  ΓΙΑ παίκτης ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 3
      ΓΡΑΨΕ 'Δώσε τους πόντους του ', παίκτης, 'ου παίκτη στον ', αγώνας, 'ο αγώνα:'
      ΔΙΑΒΑΣΕ πόντοι[παίκτης, αγώνας]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ παίκτης ΑΠΟ 1 ΜΕΧΡΙ 5
    πόντοι_παικτών[παίκτης] <-- 0
    ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 3
      πόντοι_παικτών[παίκτης] <-- πόντοι_παικτών[παίκτης] + πόντοι[παίκτης, αγώνας]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 3
    πόντοι_αγώνων[αγώνας] <-- 0
    ΓΙΑ παίκτης ΑΠΟ 1 ΜΕΧΡΙ 5
      πόντοι_αγώνων[αγώνας] <-- πόντοι_αγώνων[αγώνας] + πόντοι[παίκτης, αγώνας]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  max <-- πόντοι_παικτών[1]
  MVP <-- 1
  ΓΙΑ παίκτης ΑΠΟ 2 ΜΕΧΡΙ 5
    ΑΝ πόντοι_παικτών[παίκτης]>max ΤΟΤΕ
      max <-- πόντοι_παικτών[παίκτης]
      MVP <-- παίκτης
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  min <-- πόντοι_αγώνων[1]
  χειρότερος_αγώνας <-- 1
  ΓΙΑ αγώνας ΑΠΟ 2 ΜΕΧΡΙ 3
    ΑΝ πόντοι_αγώνων[αγώνας]<min ΤΟΤΕ
      min <-- πόντοι_αγώνων[αγώνας]
      χειρότερος_αγώνας <-- αγώνας
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ο πολυτιμότερος παίκτης της διοργάνωσης είναι ο ', MVP, 'ος παίκτης.'
  ΓΡΑΨΕ 'Ο χειρότερος αγώνας της εθνικής είναι ο ', χειρότερος_αγώνας, 'ος αγώνας.'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εθνική_Ελλάδας_μπάσκετ

 

Ενδεικτικό αρχείο δεδομένων:
(χαρακτηριστικό που υλοποιήθηκε στην έκδοση 8 της ΓλωσσοΜάθειας)
Παράθεση:
12 3 25
8 17 11
1 6 3
30 13 22
5 7 15


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters