Τώρα είναι Δευτ 01 Ιουν 2020 09:23 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 26 Μαρ 2003 11:54 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 25 Μαρ 2003 03:33 pm
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
!--------------------------------------------
! Αναζήτηση στοιχείου σε δισδιάστατο πινακα
! και εμφάνιση της πρώτης θέσης που θα βρεθεί.
!--------------------------------------------

ΠΡΟΓΡΑΜΜΑ ΑΝΑΖΗΤΗΣΗ_ΣΕ_ΔΙΣΔΙΑΣΤΑΤΟ_ΠΙΝΑΚΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΤΙΜΗ,ΘΕΣΗ_Γ,ΘΕΣΗ_Σ,Π[3,4],Ι,Κ
  ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 4
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΙΜΗ ΓΙΑ ΤΟ (', Ι,',',Κ, ') ΣΤΟΙΧΕΙΟ'
      ΔΙΑΒΑΣΕ Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΡΑΨΕ
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 4
      ΓΡΑΨΕ_ Π[Ι,Κ],'//'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΗ ΤΙΜΗ ΠΟΥ ΖΗΤΑΣ'
  ΔΙΑΒΑΣΕ ΤΙΜΗ
  ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
  Ι <-- 1
  ΟΣΟ (Ι<=3) ΚΑΙ (ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
    Κ <-- 1
    ΟΣΟ (Κ<=4) ΚΑΙ (ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
      ΑΝ Π[Ι,Κ]=ΤΙΜΗ ΤΟΤΕ
        ΒΡΕΘΗΚΕ <-- ΑΛΗΘΗΣ
        ΘΕΣΗ_Γ <-- Ι
        ΘΕΣΗ_Σ <-- Κ
        ΓΡΑΨΕ 'Η ΤΙΜΗ ',ΤΙΜΗ,' ΒΡΕΘΗΚΕ ΠΡΩΤΗ ΦΟΡΑ ΣΤΗ ΘΕΣΗ ',Ι,','
      ΑΛΛΙΩΣ
        Κ <-- Κ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- Ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Η ΤΙΜΗ ' ,ΤΙΜΗ, ' ΔΕΝ ΒΡΕΘΗΚΕ ΣΤΟΝ ΠΙΝΑΚΑ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
Elizatsi


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters