Τώρα είναι Παρ 29 Μάιος 2020 10:58 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εφοπλιστές
ΔημοσίευσηΔημοσιεύτηκε: Τετ 13 Σεπ 2006 07:13 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Ομάδα από 10 εφοπλιστές κάνει δωρεά σε 40 φιλανθρωπικές οργανώσεις. Να γράψετε πρόγραμμα το οποίο:

α) Εισάγει σε μονοδιάστατο πίνακα το όνομα κάθε εφοπλιστή, και σε άλλον μονοδιάστατο πίνακα το όνομα κάθε οργάνωσης.

β) Εισάγει σε πίνακα δύο διαστάσεων, σε ποιες οργανώσεις κάνει δωρεά ο κάθε εφοπλιστής. (καταχωρείται η λέξη «ΝΑΙ» στην περίπτωση που ο εφοπλιστής κάνει δωρεά στην συγκεκριμένη περίπτωση και «ΟΧΙ» σε αντίθετη περίπτωση.

γ) Εμφανίζει το όνομα κάθε εφοπλιστή και στη συνέχεια σε πόσες οργανώσεις κάνει δωρεά.

δ) Εμφανίζει το όνομα ή τα ονόματα των οργανώσεων που έχουν λάβει τις λιγότερες δωρεές.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Εφοπλιστες
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,Δ,Σ,ΣΔ[40],min
  ΧΑΡΑΚΤΗΡΕΣ:ΕΦΠ[10],ΟΡΓ[40],ΑΠ[10,40]
ΑΡΧΗ

! ----- α ερωτημα ------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε όνομα ',i,'ου εφοπλιστή'
    ΔΙΑΒΑΣΕ ΕΦΠ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 40
    ΓΡΑΨΕ 'Δώσε όνομα ',j,'ης οργάνωσης'
    ΔΙΑΒΑΣΕ ΟΡΓ[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ----- β ερωτημα ------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 40
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Ο εφοπλιστής ',ΕΦΠ[i],'έχει κανει δωρεά στην οργάνωση',ΟΡΓ[j],'? (ΝΑΙ,ΟΧΙ)'
        ΔΙΑΒΑΣΕ ΑΠ[i,j]
      ΜΕΧΡΙΣ_ΟΤΟΥ  (ΑΠ[i,j]='NAI') Ή (ΑΠ[i,j]='OXI')
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ----- γ ερωτημα ------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    Δ <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 40
      ΑΝ ΑΠ[i,j]='NAI' ΤΟΤΕ
        Δ <-- Δ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ΕΦΠ[i],'έχει κανει ',Δ,'δωρεές'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ----- δ ερωτημα ------
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 40
    Σ <-- 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
      ΑΝ ΑΠ[i,j]='NAI' ΤΟΤΕ
        Σ <-- Δ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΣΔ[j] <-- Σ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  min <-- ΣΔ[1]
  ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 40
    ΑΝ min<ΣΔ[j] ΤΟΤΕ
      min <-- ΣΔ[j]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 40
    ΑΝ ΣΔ[j]=min ΤΟΤΕ
      ΓΡΑΨΕ ΟΡΓ[j],'έχει λαβει τις λιγοτερες δωρεές'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  
 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters