Τώρα είναι Παρ 29 Μάιος 2020 11:46 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: μπασκετ και πάλι
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 16 Δεκ 2004 01:40 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 15 Δεκ 2004 04:26 am
Δημοσιεύσεις: 10
Τοποθεσία: Πρέβεζα
Syntax: [ Download ] [ Hide ]
!================= ΚΑΛΑΘΟΣΦΑΙΡΙΣΗ =====================================================
! ΑΣΚΗΣΗ ΠΟΥ ΠΕΡΙΕΧΕΙ ΠΟΛΛΕΣ ΑΠΑΡΑΙΤΗΤΕΣ ΓΝΩΣΕΙΣ.
!======================================================================================
! Η ομάδα μας αντιμετώπισε 9 αντιπαλες ομάδες
! Οι παίκτες μας είναι 7. Να γράψουμε αλγόριθμο που
! 1. να διαβάζει τα ονόματα των αντιπάλων ομάδων και των παικτων μας
! 2. Τους πόντους που έβαλε ο κάθε παίκτης μας σε κάθε αγώνα
! 3. να υπολογίζει τους πόντους κάθε παίκτη σε όλους τους αγώνες και
!    επίσης τους πόντους που πέτυχε ή ομάδα μας σε κάθε παίχνίδι
! 4. να υπολογίζει τον πιο εύκολο αντίπαλο (που δέχθηκε τους περισσότερους πόντους)
!    και τον πιο δύσκολο αντίπαλο (καλύτερη αντίπαλη ομάδα = δέχθηκε τους λιγότερους πόντους)
! 5. να υπολογίζει τον καλύτερο παίκτη (όλων των αγώνων)
!    και τον καλύτερο παίκτη που έπαιξε κατα της καλύτερης ομάδας (ή οποία υπολογίσθηκε πιο πάνω)
! 6. να ελέγχει εάν είναι ο καλύτερος παίκτης κατα της πιο δύσκολης αντιπάλου ο ίδιος
!   που έβαλε και τους περισσότερους πόντους σε όλους τους αγώνες (= καλύτερος παίκτης?)
!=======================================================================================
! netnick
!=======================================================================================


ΠΡΟΓΡΑΜΜΑ παικτες_basket
ΣΤΑΘΕΡΕΣ
! Για να μην πληκτρολογουμε πολές τιμές θεωρούμε πινακα 4 Χ 3 αντι 9χ7
  ΟΜΑΔΕΣ  = 4 !9
  ΠΑΙΚΤΕΣ = 3 !7
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[ΟΜΑΔΕΣ,ΠΑΙΚΤΕΣ],ΣΟ[ΟΜΑΔΕΣ], ΣΠ[ΠΑΙΚΤΕΣ],i,j, δείκτη
  ΑΚΕΡΑΙΕΣ: δείκτης_καλύτερης_ομάδας , δείκτης_χειροτερ_ομάδας
  ΑΚΕΡΑΙΕΣ: δείκτ_καλύτερ_παικτ, δείκτ_καλυτ_παικ_καλυτ_ομαδ
  ΧΑΡΑΚΤΗΡΕΣ: Ομάδα[ΟΜΑΔΕΣ], Παίκτης[ΠΑΙΚΤΕΣ]
!=======================================================================================
ΑΡΧΗ

!=======================================================================================
! Ερώτηση 1 ----------------------------------------------------------------------------
! Για να μην ασχοληθούμε με την πληκτρολόγιση δίνουμε κατευθείαν τις τιμές
! στους 2 πίνακες Ομάδων και παικτών
  Ομάδα[1] <-- 'Ολυμπιακος'
  Ομάδα[2] <-- 'Παναθηναΐκός'
  Ομάδα[3] <-- 'Αεκ'
  Ομάδα[4] <-- 'Παοκ'
!  Ομάδα[5] <-- 'Ηρακλής'
!  Ομάδα[6] <-- 'Πανιώνιος'
!  Ομάδα[7] <-- 'Δάφνη'
!  Ομάδα[8] <-- 'Σπόρτινγκ'
!  Ομάδα[9] <-- 'Άρης'

  Παίκτης[1] <-- 'Άλφα'
  Παίκτης[2] <-- 'Δέλτα'
  Παίκτης[3] <-- 'Ητα'
!  Παίκτης[4] <-- 'Θήτα'
!  Παίκτης[5] <-- 'Λάμδα'
!  Παίκτης[6] <-- 'Σίγμα'
!  Παίκτης[7] <-- 'Ωμέγα'

!=======================================================================================
! Ερώτηση 2 ----------------------------------------------------------------------------
! Διάβασμα Του κυρίως πίνακα Π[7,9]
  Για i από 1 μέχρι ΟΜΑΔΕΣ
    ΓΡΑΨΕ 'Πόντοι που έβαλε στον αγώνα με αντιπαλο την ομάδα ',Ομάδα[i]
    Για j από 1 μέχρι ΠΑΙΚΤΕΣ
      ΓΡΑΨΕ ' : ',j,' ο παίκτης  ',Παίκτης[j]
      Διάβασε Π[i,j]
    Τέλος_επανάληψης
  Τέλος_επανάληψης

! θα μπορούσαμε αντι για την διάβασε να θεωρήσουμε την Συνάρτηση ΤΥΧΑΙΟΣ() αλλά
! δεν είμαι σίγουρος αν είναι καλο για τους μαθητές να τους πάμε προς τα εκέι.
! Ο σκοπός της άσκησης είναι άλλος.

!=======================================================================================
! Ερώτηση 3 ----------------------------------------------------------------------------
!υπολογισμός αθροισμάτων ΣΠ (Σύνολο πόντων Πάικτη) και ΣΟ (Σύνολο πόντων Ομάδας)
!  Για i από 1 μέχρι ΟΜΑΔΕΣ  &#125;
!    ΣΟ[i] <-- 0             &#125;  Μηδενίζουμε ή εδώ ή όπως φαίνεται παρακάτω...
!  Τέλος_επανάληψης          &#125;

  Για i από 1 μέχρι ΠΑΙΚΤΕΣ
    ΣΠ[i] <-- 0
  Τέλος_επανάληψης

! Υπολογισμός Αθροισμάτων πόντων για κάθε παίκτη και εναντίων κάθε ομάδας.
  Για i από 1 μέχρι ΟΜΑΔΕΣ
    ΣΟ[i] <-- 0             ! ή μηδενίζουμε εδώ, 2ος τρόπος
    Για j από 1 μέχρι ΠΑΙΚΤΕΣ
      ΣΟ[i] <-- ΣΟ[i] + Π[i,j]
      ΣΠ[j] <-- ΣΠ[j] + Π[i,j]
    Τέλος_επανάληψης
    Γράψε ΣΟ[i]
  Τέλος_επανάληψης

!=======================================================================================
! Ερώτηση 4 ----------------------------------------------------------------------------
! Υπολογισμός του πιο δύσκολου και πιο εύκολου αντιπάλου
  δείκτης_καλύτερης_ομάδας <-- 1
  δείκτης_χειροτερ_ομάδας  <-- 1

  Για i από 2 μέχρι ΟΜΑΔΕΣ
    Αν ΣΟ[i] > ΣΟ[δείκτης_καλύτερης_ομάδας] ΤΟΤΕ
      δείκτης_καλύτερης_ομάδας <-- i
    ΤΕΛΟΣ_ΑΝ

    Αν ΣΟ[i] < ΣΟ[δείκτης_χειροτερ_ομάδας] ΤΟΤΕ
      δείκτης_χειροτερ_ομάδας <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!=======================================================================================
! Ερώτηση 5 ----------------------------------------------------------------------------
! Θα υπολογίσουμε τον καλύτερο παίκτη (καρτάμε μόνο τον δείκτη)
! και τον καλύτερο παίκτη που έπαιξε κατα της καλύτερης ομάδας (αυτή υπολογίσθηκε πιο πάνω)
  δείκτ_καλύτερ_παικτ <-- 1
  δείκτ_καλυτ_παικ_καλυτ_ομαδ <-- 1
  Για δείκτη από 2 μέχρι ΠΑΙΚΤΕΣ

    ΑΝ ΣΠ[δείκτη] > ΣΠ[δείκτ_καλύτερ_παικτ] ΤΟΤΕ
      δείκτ_καλύτερ_παικτ <-- δείκτη
    ΤΕΛΟΣ_ΑΝ

    ΑΝ δείκτη = δείκτης_καλύτερης_ομάδας ΤΟΤΕ
      Αν Π[δείκτης_καλύτερης_ομάδας,δείκτη] > Π[δείκτης_καλύτερης_ομάδας,δείκτ_καλυτ_παικ_καλυτ_ομαδ] ΤΟΤΕ
        δείκτ_καλυτ_παικ_καλυτ_ομαδ <-- δείκτη
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!=======================================================================================
! Ερώτηση 6 ----------------------------------------------------------------------------
! Είναι ο καλύτερος παίκτης κατα της πιο δύσκολης αντιπάλου
! ο ίδιος που έβαλε και τους περισσότερους πόντους σε όλους τους αγώνες (= καλύτερος παίκτης?)
  ΑΝ δείκτ_καλύτερ_παικτ = δείκτ_καλυτ_παικ_καλυτ_ομαδ ΤΟΤΕ
    Γραψε 'Ο Καλυτερος παίκτης όλων των αγώνων είναι ο ',Παίκτης[δείκτ_καλύτερ_παικτ]
    Γράψε 'που είναι'
    Γράψε 'και ο καλύτερος παίκτης κατά της πιο δύσκολης ομάδας: ',Ομάδα[δείκτης_καλύτερης_ομάδας]
  ΑΛΛΙΩΣ
    Γραψε 'Καλύτερος παίκτης όλων των αγώνων είναι ο ',Παίκτης[δείκτ_καλύτερ_παικτ]
    Γράψε 'ΕΝΩ'
    Γραψε 'καλύτερος παίκτης κατα της πιο δύσκολου αντιπάλου ',Ομάδα[δείκτης_καλύτερης_ομάδας]
    Γράψε 'είναι ο ',Παίκτης[δείκτ_καλυτ_παικ_καλυτ_ομαδ]
  ΤΕΛΟΣ_ΑΝ
!=======================================================================================

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ παικτες_basket

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters