Τώρα είναι Πέμ 27 Ιουν 2019 03:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Κλήρωση λόττο
ΔημοσίευσηΔημοσιεύτηκε: Τετ 09 Μάιος 2007 10:03 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 09 Μάιος 2007 09:57 pm
Δημοσιεύσεις: 1
Σε κάθε κλήρωση λόττο κληρώνονται 6 διαφορετικοί αριθμοί από το 1 μέχρι το 49. Αν δίνεται πίνακας Α[100,6] με τα αποτελέσματα 100 κληρώσεων στο λόττο να γραφτεί πρόγραμμα το οποίο να διαβάζει τους 6 αριθμούς που έχει επιλέξει ένας παίκτης και να υπολογίζει και να εμφανίζει σε ποια κλήρωση είχε τις περισσότερες επιτυχίες.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Κλήρωση λόττο
ΔημοσίευσηΔημοσιεύτηκε: Τετ 24 Φεβ 2010 09:07 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 24 Φεβ 2010 08:57 pm
Δημοσιεύσεις: 1
Αφού δεν δίνει τη λύση ο συγγραφέας της εκφώνησης, προσπάθησα να καταλάβω τι ζητάει και...

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ LOTTO
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,Γ,ΚΛΗΡΩΣΕΙΣ[100,6],ΠΑΙΚΤΗΣ[6],ΕΠΙΤΥΧΙΕΣ[100],ΘΕΣΗ_ΜΕΓΙΣΤΟ,ΜΕΓΙΣΤΟ
  ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΥΣ ΑΡΙΘΜΟΥΣ ΤΩΝ ΚΛΗΡΩΣΕΩΝ'
  ΓΡΑΨΕ '================================'
  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ 'ΚΛΗΡΩΣΗ'
    ΓΡΑΨΕ '========='                  
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ 'ΑΡΙΘΜΟΣ'
      ΔΙΑΒΑΣΕ ΚΛΗΡΩΣΕΙΣ[Α,Β]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΥΣ ΑΡΙΘΜΟΥΣ ΤΟΥ ΠΑΙΚΤΗ (1-49)'
  ΓΡΑΨΕ '============================='
  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΡΑΨΕ 'ΑΡΙΘΜΟΣ'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ !ΕΛΕΓΧΕΙ ΑΝ Ο ΑΡΙΘΜΟΣ ΥΠΑΡΧΕΙ ΗΔΗ ΚΑΙ ΑΝ ΕΙΝΑΙ ΕΚΤΟΣ ΟΡΙΩΝ
      ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
      ΔΙΑΒΑΣΕ ΠΑΙΚΤΗΣ[Α]
      ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ Α-1
        ΑΝ ΠΑΙΚΤΗΣ[Α]=ΠΑΙΚΤΗΣ[Β] ΤΟΤΕ
          ΒΡΕΘΗΚΕ <-- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ ΒΡΕΘΗΚΕ=ΑΛΗΘΗΣ ΤΟΤΕ
        ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΠΟΥ ΕΔΩΣΕΣ ΥΠΑΡΧΕΙ ΗΔΗ. ΔΩΣΕ ΞΑΝΑ ΑΡΙΘΜΟ'
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ΠΑΙΚΤΗΣ[Α]<1 Η ΠΑΙΚΤΗΣ[Α]>49 ΤΟΤΕ
        ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΠΟΥ ΕΔΩΣΕΣ ΕΙΝΑΙ ΕΚΤΟΣ ΟΡΙΩΝ (1-49). ΔΩΣΕ ΞΑΝΑ ΑΡΙΘΜΟ'
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ ΚΑΙ ΠΑΙΚΤΗΣ[Α]>=1 ΚΑΙ ΠΑΙΚΤΗΣ[Α]<=49
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!ΜΗΔΕΝΙΣΜΟΣ ΠΙΝΑΚΑ ΕΠΙΤΥΧΙΩΝ ΑΝΑ ΚΛΗΡΩΣΗ
  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 100
    ΕΠΙΤΥΧΙΕΣ[Α] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 6 !ΜΕΤΡΑΕΙ ΤΟΥΣ ΑΡΙΘΜΟΥΣ ΤΟΥ ΠΑΙΚΤΗ
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 100
      ΓΙΑ Γ ΑΠΟ 1 ΜΕΧΡΙ 6
        !ΕΛΕΓΧΕΙ ΓΙΑ ΚΑΘΕ ΑΡΙΘΜΟ ΤΟΥ ΠΑΙΚΤΗ (ΜΕΤΡΗΤΗΣ Α) ΑΝ ΥΠΑΡΧΕΙ ΣΤΗ ΣΥΓΚΕΚΡΙΜΕΝΗ ΚΛΗΡΩΣΗ (ΜΕΤΡΗΤΗΣ Β)
        ΑΝ ΚΛΗΡΩΣΕΙΣ[Β,Γ]=ΠΑΙΚΤΗΣ[Α] ΤΟΤΕ
          ΕΠΙΤΥΧΙΕΣ[Β] <-- ΕΠΙΤΥΧΙΕΣ[Β]+1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!ΕΥΡΕΣΗ ΜΕΓΙΣΤΟΥ ΣΤΟΝ ΠΙΝΑΚΑ ΕΠΙΤΥΧΙΕΣ
  ΘΕΣΗ_ΜΕΓΙΣΤΟ <-- 1
  ΜΕΓΙΣΤΟ <-- ΕΠΙΤΥΧΙΕΣ[1]
  ΓΙΑ Α ΑΠΟ 2 ΜΕΧΡΙ 100
    ΑΝ ΕΠΙΤΥΧΙΕΣ[Α]> ΜΕΓΙΣΤΟ ΤΟΤΕ
      ΘΕΣΗ_ΜΕΓΙΣΤΟ <-- Α
      ΜΕΓΙΣΤΟ <-- ΕΠΙΤΥΧΙΕΣ[Α]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο ΠΑΙΚΤΗΣ ΕΙΧΕ ΤΙΣ ΠΕΡΙΣΣΟΤΕΡΕΣ ΕΠΙΤΥΧΙΕΣ (',ΜΕΓΙΣΤΟ,') ΣΤΗΝ',ΘΕΣΗ_ΜΕΓΙΣΤΟ,'ΚΛΗΡΩΣΗ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters