Τώρα είναι Παρ 10 Απρ 2020 04:10 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 7 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μιγαδικοί
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 16 Ιούλ 2011 11:02 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 16 Ιούλ 2011 11:00 am
Δημοσιεύσεις: 4
θα ήθελα βοήθεια για να φτιάξω ένα πρόγραμμα που να υπολογίζει τον μιγαδικό αριθμό i για ν=4κ ν=4κ+1 ν=4κ+2 ν=4κ+3
έχω κολλήσει :?


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μιγαδικοί
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 16 Ιούλ 2011 02:02 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Θα βοηθούσε αν διατύπωνες το πρόβλημα λίγο καλύτερα... Εννοείς να υπολογίζει την ν-ιοστή δύναμη του i ?
Καλό θα ήταν να μοιραστείς μαζί μας και τις ιδέες σου για να σε βοηθήσουμε εκεί που δυσκολεύεσαι... το να σου δώσουμε την απάντηση κατευθείαν ελάχιστα θα σε βοηθήσει.

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μιγαδικοί
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 16 Ιούλ 2011 02:23 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 16 Ιούλ 2011 11:00 am
Δημοσιεύσεις: 4
ναι την ν-ιοστή δύναμη του i.στο ΔΙΑΒΑΣΕ βαζω ν,κ και τη σχέση i^ν<--(i^υ).αλλά δεν ξέρω αν τα κάνω σωστά


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μιγαδικοί
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 16 Ιούλ 2011 02:54 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
το ι δεν σημαίνει κάτι για την γλώσσα παρά μόνο ως όνομα μεταβλητής. το ι^ν <-- ι^υ πρέπει να σου δίνει σφάλμα επειδή το ι^ν θεωρείται πράξη. Επίσης η γλώσσα δεν υποστηρίζει μιγαδικούς οπότε θα πρέπει να χρησιμοποιήσεις συνθήκες για να βρεις την απάντηση (ανάλογα με το υ (υπόλοιπο ακέραιας διαίρεσης του ν με το 4), το οποίο μπορείς να το βρίσκεις χρησιμοποιώντας mod). Το κ δεν χρειάζεται να το διαβάζεις καθώς μπορείς να το βρεις χρησιμοποιώντας div, αφού έχεις το ν, αλλά έτσι και αλλιώς είναι άχρηστο, εκτός αν έχω καταλάβει λάθος το πρόβλημα. Το αποτέλεσμα θα χρειάζεται να εκτυπώνεις το αποτέλεσμα ως αλφαριθμητικό αποτέλεσμα. Κάνε μια προσπάθεια προσέχοντας τα παραπάνω και αν δεν σε βοήθησαν, πες μου.
ΥΓ. Ελπίζω να μπορείς να καταλάβεις τι γράφω γιατί τα έγραψα λίγο βιαστικά.

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μιγαδικοί
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 16 Ιούλ 2011 06:28 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 16 Ιούλ 2011 11:00 am
Δημοσιεύσεις: 4
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΙΓΑΔΙΚΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:ν,υ
ΑΡΧΗ
ΔΙΑΒΑΣΕ ν
υ<-- ν MOD 4
i<--υ


έφτασα μεχρί εδώ καλά παω? μετά κολλάω βέβαια


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μιγαδικοί
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 17 Ιούλ 2011 10:38 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Καλά πας. Τα ν, υ πρέπει να είναι ακέραιοι λόγω της εκφώνησης (και για να ορίζεται το mod). το ι πρέπει να δηλωθεί όπως και κάθε άλλη μεταβλητή, ΔΕΝ ΔΙΑΦΕΡΕΙ σε τίποτα από οποιαδήποτε άλλη μεταβλητή καθώς ο υπολογιστής δεν ξέρει ότι μιλάς για μιγαδικούς. Οπότε :
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΙΓΑΔΙΚΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ν, υ
           
ΑΡΧΗ
  ΔΙΑΒΑΣΕ ν
  υ <-- (ν MOD 4)  

(τα κενά μετά το ν και πριν το 4 είναι υποχρεωτικά)
Στη συνέχεια θα πρέπει να διακρίνεις περιπτώσεις ανάλογα με το υ.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΙΓΑΔΙΚΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ν, υ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠΟΤ[4]            
ΑΡΧΗ
  ΔΙΑΒΑΣΕ ν
  υ <-- (ν MOD 4)
  ΕΠΙΛΕΞΕ υ
    ΠΕΡΙΠΤΩΣΗ 0
      ΓΡΑΨΕ '1'
    ΠΕΡΙΠΤΩΣΗ 1
      ΓΡΑΨΕ 'i'  
    ΠΕΡΙΠΤΩΣΗ 2
      ΓΡΑΨΕ '-1'
    ΠΕΡΙΠΤΩΣΗ 3
      ΓΡΑΨΕ '-i'
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
                       
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ή
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΙΓΑΔΙΚΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ν, υ
       
ΑΡΧΗ
  ΔΙΑΒΑΣΕ ν
  υ <-- (ν MOD 4)
  ΑΝ υ DIV 2<>0 ΤΟΤΕ
    ΓΡΑΨΕ_ '-'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ υ MOD 2 = 0 ΤΟΤΕ
    ΓΡΑΨΕ 1
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'i'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ή μιας και είμαστε στις δομές ακολουθίας :wink: :
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΙΓΑΔΙΚΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ν, υ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠΟΤ[4]            
ΑΡΧΗ
  ΔΙΑΒΑΣΕ ν
  υ <-- (ν MOD 4)  
  ΑΠΟΤ[1] <-- '1'
  ΑΠΟΤ[2] <-- 'i'  
  ΑΠΟΤ[3] <-- '-1'
  ΑΠΟΤ[4] <-- '-i'
  ΓΡΑΨΕ ΑΠΟΤ[υ+1]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μιγαδικοί
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Ιούλ 2011 07:01 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 16 Ιούλ 2011 11:00 am
Δημοσιεύσεις: 4
σε ευχαριστώ πάρα πολύ! να είσαι καλα


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 7 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters