Τώρα είναι Παρ 10 Απρ 2020 09:38 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: MOD_01
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 12 Οκτ 2003 11:40 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
!___________________________________________________
!
!  Να γραφεί αλγόριθμος που να δέχεται έναν αριθμό και
!  να εμφανίζει το αποτέλεσμα της διαίρεσης του αριθμού
!  αυτού με το τελευταίο ψηφίο του (το ψηφίο των μονάδων).
!___________________________________________________

ΠΡΟΓΡΑΜΜΑ MOD_01
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x , last
  ΠΡΑΓΜΑΤΙΚΕΣ: y
ΑΡΧΗ
  ΔΙΑΒΑΣΕ x
  last <-- x MOD 10
  ΑΝ last = 0 TOTE
     ΓΡΑΨΕ 'Δε μπορεί να γίνει η διαίρεση αφού το τελευταίο ψηφίο είναι μηδέν.'
  ΑΛΛΙΩΣ
     y <--    x / last
     ΓΡΑΨΕ y
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ MOD_01
 


Τελευταία επεξεργασία από ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ και Σάβ 17 Απρ 2010 10:31 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: MOD_01
ΔημοσίευσηΔημοσιεύτηκε: Τρί 29 Σεπ 2009 10:29 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 29 Σεπ 2009 10:23 am
Δημοσιεύσεις: 1
Σε περίπτωση που το τελευταίο ψηφίο είναι 0, το πρόγραμμα σου παραβιάζει το κριτήριο της καθοριστικότητας (διαίρεση με 0). Αντιμετώπισέ το με την εντολή επιλογής μετά την εύρεση του last. :shock:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: MOD_01
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 17 Απρ 2010 10:32 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Σωστός.
Το διόρθωσα.
Ευχαριστώ για την παρατήρηση.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters