Τώρα είναι Παρ 10 Απρ 2020 09:09 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 08 Αύγ 2010 06:14 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 08 Αύγ 2010 04:11 pm
Δημοσιεύσεις: 8
ειμαι μαθητης της γ λυκείου(σε κανα μηνα και επισημα), δεν ξερω ακομα πολλα απο προγραμματισμο και ελπιζω το προγραμματακι μου να ειναι σωστο........η ιδεα για το συγκεκριμενο μου ηρθε μια μερα στο πρακτορειο οταν επαιζα στοιχημα και πιστευω πως ειναι χρησιμο προγραμματακι....... :mrgreen: :mrgreen: :mrgreen: :mrgreen: :lol: :lol: :lol: :lol:

Syntax: [ Download ] [ Hide ]
 ΠΡΟΓΡΑΜΜΑ   στοίχημα_3_παικτες
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟ1,ΠΟΣΟ2,ΠΟΣΟ3,Σ_ΠΟΣΟ,ΚΕΡΔΗ,ΚΕΡΔΗ1,ΚΕΡΔΗ2,ΚΕΡΔΗ3
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ1,ΟΝΟΜΑ2,ΟΝΟΜΑ3
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΠΟΣΟ ΣΥΜΜΕΤΟΧΗΣ'
  ΔΙΑΒΑΣΕ ΟΝΟΜΑ1,ΠΟΣΟ1
  ΓΡΑΨΕ'ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΠΟΣΟ ΣΥΜΜΕΤΟΧΗΣ'
  ΔΙΑΒΑΣΕ ΟΝΟΜΑ2,ΠΟΣΟ2
  ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΠΟΣΟ ΣΥΜΜΕΤΟΧΗΣ'
  ΔΙΑΒΑΣΕ ΟΝΟΜΑ3,ΠΟΣΟ3
  ΓΡΑΨΕ 'ΔΩΣΕ ΚΕΡΔΗ'
  ΔΙΑΒΑΣΕ ΚΕΡΔΗ
  Σ_ΠΟΣΟ <-- ΠΟΣΟ1+ΠΟΣΟ2+ΠΟΣΟ3
  ΚΕΡΔΗ1 <-- ΠΟΣΟ1/Σ_ΠΟΣΟ*ΚΕΡΔΗ
  ΚΕΡΔΗ2 <-- ΠΟΣΟ2/Σ_ΠΟΣΟ*ΚΕΡΔΗ
  ΚΕΡΔΗ3 <-- ΠΟΣΟ3/Σ_ΠΟΣΟ*ΚΕΡΔΗ
  ΓΡΑΨΕ 'Ο',ΟΝΟΜΑ1,'ΠΑΙΡΝΕΙ',ΚΕΡΔΗ1,'ΕΥΡΩ,Ο',ΟΝΟΜΑ2,'ΠΑΙΡΝΕΙ',ΚΕΡΔΗ2,'ΕΥΡΩ ΚΑΙ Ο',ΟΝΟΜΑ3,'ΠΑΙΡΝΕΙ',ΚΕΡΔΗ3,'ΕΥΡΩ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  στοίχημα_3_παικτες


Συνημμένα:
diagramma rois stoixima.jpg
diagramma rois stoixima.jpg [ 83.37 KiB | 2874 προβολές ]
Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Αύγ 2010 10:33 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 08 Αύγ 2010 04:11 pm
Δημοσιεύσεις: 8
και λιγο πιο περιπλοκο............

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   στοίχημα_3_παικτες
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟ1,ΠΟΣΟ2,ΠΟΣΟ3,Σ_ΠΟΣΟ,ΚΕΡΔΗ,ΚΕΡΔΗ1,ΚΕΡΔΗ2,ΚΕΡΔΗ3,α,λ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ1,ΟΝΟΜΑ2,ΟΝΟΜΑ3
ΑΡΧΗ
  λ <-- 1
  ΟΣΟ λ=1  ΕΠΑΝΑΛΑΒΕ

    ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΠΟΣΟ ΣΥΜΜΕΤΟΧΗΣ'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ1,ΠΟΣΟ1
    ΓΡΑΨΕ'ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΠΟΣΟ ΣΥΜΜΕΤΟΧΗΣ'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ2,ΠΟΣΟ2
    ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΚΑΙ ΠΟΣΟ ΣΥΜΜΕΤΟΧΗΣ'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ3,ΠΟΣΟ3
    ΓΡΑΨΕ 'ΔΩΣΕ ΚΕΡΔΗ'
    ΔΙΑΒΑΣΕ ΚΕΡΔΗ
    Σ_ΠΟΣΟ <-- ΠΟΣΟ1+ΠΟΣΟ2+ΠΟΣΟ3
    ΚΕΡΔΗ1 <-- ΠΟΣΟ1/Σ_ΠΟΣΟ*ΚΕΡΔΗ
    ΚΕΡΔΗ2 <-- ΠΟΣΟ2/Σ_ΠΟΣΟ*ΚΕΡΔΗ
    ΚΕΡΔΗ3 <-- ΠΟΣΟ3/Σ_ΠΟΣΟ*ΚΕΡΔΗ
    ΓΡΑΨΕ 'Ο',ΟΝΟΜΑ1,'ΠΑΙΡΝΕΙ',ΚΕΡΔΗ1,'ΕΥΡΩ,Ο',ΟΝΟΜΑ2,'ΠΑΙΡΝΕΙ',ΚΕΡΔΗ2,'ΕΥΡΩ ΚΑΙ Ο',ΟΝΟΜΑ3,'ΠΑΙΡΝΕΙ',ΚΕΡΔΗ3,'ΕΥΡΩ'
    ΓΡΑΨΕ 'ΕΠΕΛΕΞΕ 1 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ Ή 2 ΓΙΑ ΕΠΑΝΕΚΤΕΛΕΣΗ'
    ΔΙΑΒΑΣΕ α
    ΑΝ α=1  ΤΟΤΕ
      λ <-- 2
      ΓΡΑΨΕ 'ΠΑΝΤΑ ΤΕΤΟΙΑ'
    ΑΛΛΙΩΣ_ΑΝ α=2  ΤΟΤΕ
      λ <-- 1

    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  στοίχημα_3_παικτες


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters