Τώρα είναι Παρ 10 Απρ 2020 07:55 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΝΤΙΣΤΡΟΦΗ ΑΡΙΘΜΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 08 Οκτ 2008 08:40 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 08 Οκτ 2008 08:36 pm
Δημοσιεύσεις: 1
Θα μπορούσε κάποιος να με βοηθήσει στο εξής πρόβλημα:
Θέλω να διαβάζει έναν φυσικό τριψήφιο αριθμό και αφού κάνει αντιμετάθεση των ψηφίων (π.χ. 483 - 384) να εμφανίζει τη διαφορά των δυο αριθμών.

Σημ. Υπάρχει αναρτημένο πρόγραμμα με 1-10 ψηφία αλλά εγώ θέλω μόνο με τρία

Ευχαριστώ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΑΝΤΙΣΤΡΟΦΗ ΑΡΙΘΜΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 08 Οκτ 2008 11:33 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 21 Σεπ 2008 05:49 pm
Δημοσιεύσεις: 5
Συναδελφε προγραμματιστη,
προτεινω το εξης προγραμμα για θετικους, ομως, τριψηφιους:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Απομόνωση_ψηφίων_κ_ευρεση_διαφορας

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x, ψ1, ψ2, ψ3, υπόλοιπο, ω, γ

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε έναν θετικο τριψήφιο αριθμό:'
    ΔΙΑΒΑΣΕ x
    ΑΝ x<100 Ή x>999 ΤΟΤΕ
      ΓΡΑΨΕ 'Ο αριθμός αυτός δεν είναι θετικος τριψήφιος'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ x>=100 ΚΑΙ x<=999

  ψ1 <-- x DIV 100
  υπόλοιπο <-- x MOD 100
  ψ2 <-- υπόλοιπο DIV 10
  ψ3 <-- υπόλοιπο MOD 10

  ΓΡΑΨΕ 'Τα ψηφία του αριθμού είναι:', ψ1, ψ2, ψ3

  ω <-- ψ3*100+ψ2*10+ψ1
  γράψε 'Με αντιμεταθεση ψηφιων προκυπτει ο αριθμος:', ω
  γ <-- Α_Τ(ω-x)
  γράψε 'Η απολυτη τιμη της διαφορας τους ειναι: |',ω,'-',x,'| =', γ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Απομόνωση_ψηφίων_κ_ευρεση_διαφορας


Αν σκεφτω τιποτα για ολοκληρο το συνολο των ακεραιων θα το ποσταρω.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Google [Bot] και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters