Τώρα είναι Τρί 07 Ιούλ 2020 10:02 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Στρογγυλοποίηση Ακεραίου *
ΔημοσίευσηΔημοσιεύτηκε: Παρ 24 Νοέμ 2006 02:52 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Να διαβασθεί ένας ακέραιος αριθμός και να στρογγυλοποιηθεί στα δύο τελευταία ψηφία του. Δηλαδή, αν ο αριθμός είναι ο 15732 να γίνει 15700 και αν είναι ο 15784 να γίνει 15800.Αν ήταν ο 45 να γίνει 0, ενώ αν ήταν ο 70 να γίνει 100.

Το πρόβλημα λύνεται εύκολα με τη χρήση της εντολής ΑΝ , δοκιμάστε να το λύσετε όμως χωρίς την εντολή ΑΝ, μονο με τις εντολές της Δομής Ακολουθίας.


ΛΥΣΗ 1η: ΜΟΝΟ με ΔΟΜΗ ΑΚΟΛΟΥΘΙΑΣ :D

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Στρογγυλοποίηση_Ακεραιου
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Α
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε ακεραιο αριθμό'
  ΔΙΑΒΑΣΕ Α
  Α <-- Α+50
  Α <-- Α DIV 100 * 100
  ΓΡΑΨΕ 'Στρογγυλοποιημενος αριθμος='
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



ΛΥΣΗ 2η: και με ΔΟΜΗ ΕΠΙΛΟΓΗΣ

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Στρογγυλοποίηση_Ακεραιου
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Α,last
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε ακεραιο αριθμό'
  ΔΙΑΒΑΣΕ Α
  last <-- Α MOD 100
  Α <-- Α-last
  ΑΝ 50<last ΤΟΤΕ
    Α <-- Α+100
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Στρογγυλοποιημενος αριθμος='
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters