Τώρα είναι Παρ 10 Απρ 2020 03:38 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Δόμηση χρονικής διάρκειας
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:41 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =====================================================
! Να γίνει πρόγραμμα που να ζητάει έναν αριθμό
! δευτερολέπτων και να εμφανίζει σε πόσες ώρες, λεπτά
! και δευτερόλεπτα αντιστοιχεί.
! =====================================================


ΠΡΟΓΡΑΜΜΑ Δόμηση_χρονικής_διάρκειας

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: χρόνος, ώρες, λεπτά, δευτερόλεπτα, υπόλοιπο

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε τη χρονική διάρκεια σε δευτερόλεπτα:'
  ΔΙΑΒΑΣΕ χρόνος

  ώρες <-- χρόνος DIV 3600
  υπόλοιπο <-- χρόνος MOD 3600
  λεπτά <-- υπόλοιπο DIV 60
  δευτερόλεπτα <-- υπόλοιπο MOD 60

  ΓΡΑΨΕ 'Αυτή η χρονική διάρκεια αντιστοιχεί σε:'
  ΓΡΑΨΕ ώρες, ' ώρες,'
  ΓΡΑΨΕ λεπτά, ' λεπτά,'
  ΓΡΑΨΕ δευτερόλεπτα, ' δευτερόλεπτα.'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Δόμηση_χρονικής_διάρκειας

 


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 19 Οκτ 2003 01:35 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2003 12:44 pm
Δημοσιεύσεις: 4
Τοποθεσία: Drama, Greece
Ενδιαφέρουσα παραλλαγή (με λιγότερες μεταβλητές) του προβλήματος μετατροπής δευτερολέπτων σε ώρες:λεπτά:δευτερόλεπτα.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ χρόνος
ΣΤΑΘΕΡΕΣ
   δευτερόλεπτα_ώρας=3600
   δευτερόλεπτα_λεπτού=60
ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: ώρες, λεπτά, δευτερόλεπτα
ΑΡΧΗ
   ΓΡΑΨΕ 'Δώσε τη χρονική διάρκεια σε δευτερόλεπτα:'
   ΔΙΑΒΑΣΕ δευτερόλεπτα
   ώρες <-- δευτερόλεπτα DIV δευτερόλεπτα_ώρας
   δευτερόλεπτα <-- δευτερόλεπτα - ώρες*δευτερόλεπτα_ώρας
   λεπτά <-- δευτερόλεπτα DIV δευτερόλεπτα_λεπτού
   δευτερόλεπτα <-- δευτερόλεπτα - λεπτά*δευτερόλεπτα_λεπτού
   ΓΡΑΨΕ 'Αυτή η χρονική διάρκεια αντιστοιχεί σε: ', ώρες, ':', λεπτά, ':', δευτερόλεπτα
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Ακομα λιγοτεροι μεταβλητες
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Νοέμ 2003 04:50 pm 
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ χρονος
ΣΤΑΘΕΡΕΣ
  dh=3600
  dl=60
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: sec
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τη χρονική διάρκεια σε δευτερόλεπτα:'
  ΔΙΑΒΑΣΕ sec
  ΓΡΑΨΕ 'ωρες: ',  sec DIV dh, '  λεπτα: ', sec MOD dh DIV dl, '  δευτερολεπτα: ', sec MOD dh MOD dl
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 05 Οκτ 2004 11:14 pm 
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΩΡΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: SEC, ΩΡΕΣ, ΛΕΠΤΑ, ΔΕΥΤΕΡΑ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΑ ΔΕΠΤΕΡΟΛΕΠΤΑ'
  ΔΙΑΒΑΣΕ SEC
  ΩΡΕΣ <-- SEC DIV 3600
  ΛΕΠΤΑ <-- (SEC MOD 3600) DIV 60
  ΔΕΥΤΕΡΑ <-- (SEC MOD 3600) MOD 60
  ΓΡΑΨΕ 'Ο ΧΡΟΝΟΣ ΕΙΝΑΙ ', ΩΡΕΣ, ' ΩΡΕΣ ', ΛΕΠΤΑ, ' ΛΕΠΤΑ ΚΑΙ ', ΔΕΥΤΕΡΑ, ' ΔΕΠΤΕΡΟΛΕΠΤΑ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΩΡΑ


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters